9511 C++ Programming Manual: D:/OneDrive/Desktop/9511/C++/JY9511.h File Reference

9511 C++ Programming Manual
  • Main Page
  • Classes
  • Files
  • File List
  • File Members
  • OneDrive
  • Desktop
  • 9511
  • C++
Classes | Typedefs | Enumerations | Functions
JY9511.h File Reference

Classes

struct JY9511_info

Typedefs

typedef void * JY9511_DeviceHandle
Windows.

Enumerations

enum | JY9511_ReferenceClockSource { JY9511_Internal = 0 , JY9511_External = 1 }
enum | JY9511_ExteranlReferenceClockTerminal { JY9511_Clock_In = 0 , JY9511_PXIe_Clk100 = 1 }
enum JY9511_DigitalTriggerSource {
JY9511_PFI0 = 0x0 , JY9511_PXI_Trig0 = 0x1 , JY9511_PXI_Trig1 = 0x2 , JY9511_PXI_Trig2 = 0x3 ,
JY9511_PXI_Trig3 = 0x4 , JY9511_PXI_Trig4 = 0x5 , JY9511_PXI_Trig5 = 0x6 , JY9511_PXI_Trig6 = 0x7 ,
JY9511_PXI_Trig7 = 0x8 , JY9511_Inter_AI_StartTrig = 0x9 , JY9511_Inter_AI_ReferenceTrig = 0x10 , JY9511_Inter_AO_StartTrig = 0x11 ,
JY9511_Inter_Counter_0_StartTrig =0X12
}
enum | JY9511_Terminal { JY9511_PseudoDifference = 0 , JY9511_Difference = 1 }
enum | JY9511_DigitalTriggerEdge { JY9511_Rising = 0 , JY9511_Falling = 1 }
enum | JY9511_TriggerMode { JY9511_StartTrigger = 0x0 , JY9511_ReferenceTrigger = 0x1 }
enum JY9511_Signal_Source {
JY9511_Signal_PFI_0 = 0 , JY9511_Signal_PXI_Trig_0 = 1 , JY9511_Signal_PXI_Trig_1 = 2 , JY9511_Signal_PXI_Trig_2 = 3 ,
JY9511_Signal_PXI_Trig_3 = 4 , JY9511_Signal_PXI_Trig_4 = 5 , JY9511_Signal_PXI_Trig_5 = 6 , JY9511_Signal_PXI_Trig_6 = 7 ,
JY9511_Signal_PXI_Trig_7 = 8 , JY9511_AI_StartTrig = 9 , JY9511_AI_ReferenceTrig = 10 , JY9511_AO_StartTrig = 11 ,
JY9511_Signal_CI_0_StartTrig = 12 , JY9511_Signal_CI_0_SampleClock = 13 , JY9511_Signa_Counter_0_EventOut = 14
}
enum | JY9511_DeviceProperty { JY9511_Independent = 0 , JY9511_MASTER = 1 , JY9511_SLAVE = 2 }
enum JY9511_Signal_Destination {
JY9511_PFI0_OUT = 0 , JY9511_PXITrig0_OUT = 1 , JY9511_PXITrig1_OUT = 2 , JY9511_PXITrig2_OUT = 3 ,
JY9511_PXITrig3_OUT = 4 , JY9511_PXITrig4_OUT = 5 , JY9511_PXITrig5_OUT = 6 , JY9511_PXITrig6_OUT = 7 ,
JY9511_PXITrig7_OUT = 8
}
enum JY9511_AI_Range {
JY9511_AI_Range_0p3125V = 0 , JY9511_AI_Range_0p625V = 1 , JY9511_AI_Range_1p25V = 2 , JY9511_AI_Range_2p5V = 3 ,
JY9511_AI_Range_5V = 4 , JY9511_AI_Range_10V = 5 , JY9511_AI_Range_25V = 6 , JY9511_AI_Range_50V = 7
}
enum | JY9511_AI_Coupling { JY9511_AC = 1 , JY9511_DC = 0 }
enum | JY9511_AI_SampleMode { JY9511_AI_Finite = 0 , JY9511_AI_Continuous = 1 , JY9511_AI_Single = 2 }
enum | JY9511_AI_TriggerType { JY9511_AI_Immediately = 0 , JY9511_AI_Digital = 1 , JY9511_AI_Software = 2 , JY9511_AI_Analog = 3 }
enum | JY9511_AnalogTriggerSource { JY9511_Channel_0 = 0 , JY9511_Channel_1 = 1 , JY9511_Channel_2 = 2 , JY9511_Channel_3 = 3 }
enum | JY9511_AnalogWindowCondition { JY9511_Entering = 0x0 , JY9511_Leaving = 0x1 }
enum | JY9511_AnalogTriggerEdge { JY9511_RisingSlope = 0x0 , JY9511_FallingSlope = 0x1 }
enum | JY9511_IEPEConnectionStatus { JY9511_IEPEConnection_Normal = 0 , JY9511_IEPEConnection_Open = 1 , JY9511_IEPEConnection_Short = 2 }
enum | JY9511_AI_LPFMode { JY9511_AI_LPF_Normal = 0 , JY9511_AI_LPF_WideBandwidth = 1 }
enum | JY9511_AO_UpdateMode { JY9511_AO_Finite = 0x0 , JY9511_AO_ContinuousWrapping = 0x1 , JY9511_AO_ContinuousNoWrapping = 0x2 , JY9511_AO_DDS = 0x3 }
enum | JY9511_AO_Range { JY9511_AO_Range_0p316V = 0 , JY9511_AO_Range_1V = 1 , JY9511_AO_Range_3p16V = 2 , JY9511_AO_Range_10V = 3 }
enum | JY9511_AO_TriggerType { JY9511_AO_Immediately = 0 , JY9511_AO_Digital = 1 , JY9511_AO_Software = 2 }
enum | JY9511_CI_SampleMode { JY9511_CI_Finite = 0x0 , JY9511_CI_Continuous = 0x1 , JY9511_CI_Single = 0x2 }
enum | JY9511_CI_MeasureType { JY9511_CI_EdgeCount = 0 , JY9511_CI_Measure_FrequencyOrPeriod = 1 , JY9511_CI_Measure_PulseWidth = 2 , JY9511_CI_Measure_SemiPeriod = 3 }
enum | JY9511_CountDirection { JY9511_CI_Count_Up , JY9511_CI_Count_Down , JY9511_CI_Count_External }
enum | JY9511_CI_SampleClock { JY9511_CI_ImplicitClock , JY9511_CI_InternalClock , JY9511_CI_ExternalClock }
enum | JY9511_CI_CounterEventSignalIdleState { JY9511_CI_CounterEventSignalIdleState_Low = 0 , JY9511_CI_CounterEventSignalIdleState_High = 1 }
enum | JY9511_LevelState { JY9511_LowLevel = 0 , JY9511_HighLevel = 1 }
enum | JY9511_CI_StartingEdge { JY9511_RisingEdge = 0 , JY9511_FallingEdge = 1 , JY9511_AnyEdge = 2 }
enum JY9511_InputTerminal {
JY9511_PFI0_Input = 0 , JY9511_PXI_Trig0_Input = 1 , JY9511_PXI_Trig1_Input = 2 , JY9511_PXI_Trig2_Input = 3 ,
JY9511_PXI_Trig3_Input = 4 , JY9511_PXI_Trig4_Input = 5 , JY9511_PXI_Trig5_Input = 6 , JY9511_PXI_Trig6_Input = 7 ,
JY9511_PXI_Trig7_Input = 8 , JY9511_AI_SampleClock_Input = 9 , JY9511_AO_SampleClock_Input = 10 , JY9511_CI_100MHz_Input = 11 ,
JY9511_CI_5MHz_Input = 12 , JY9511_CI_100kHz_Input = 13 , JY9511_AI_MCLK_Input = 14
}
enum JY9511_CountTimeBase {
JY9511_Internal_Timebase_100M = 0x0 , JY9511_Internal_Timebase_5M = 0x1 , JY9511_Internal_Timebase_100K = 0x2 , JY9511_External_Timebase = 0x3 ,
JY9511_MCLK_Timebase = 0x4
}
enum | JY9511_CI_TriggerType { JY9511_CIO_Immediately = 0x0 , JY9511_CIO_Digital = 0x1 , JY9511_CIO_Soft = 0x3 }
enum JY9511_ExternalClockTerminal {
JY9511_Clock_PXI_Trig_0 = 0 , JY9511_Clock_PXI_Trig_1 = 1 , JY9511_Clock_PXI_Trig_2 = 2 , JY9511_Clock_PXI_Trig_3 = 3 ,
JY9511_Clock_PXI_Trig_4 = 4 , JY9511_Clock_PXI_Trig_5 = 5 , JY9511_Clock_PXI_Trig_6 = 6 , JY9511_Clock_PXI_Trig_7 = 7
}

Functions

JY9511_API int | JY9511_Open (int slotNumber, JY9511_DeviceHandle *hDevice)
打开板卡
JY9511_API int | JY9511_OpenByName (const char *cardName, JY9511_DeviceHandle *hDevice)
以别名打开板卡
JY9511_API int | JY9511_Close (JY9511_DeviceHandle hDevice)
关闭设备，释放句柄
JY9511_API int | JY9511_GetDeviceSerialNumber (JY9511_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber.
JY9511_API int | JY9511_SetDeviceReferenceClock (JY9511_DeviceHandle hDevice, JY9511_ReferenceClockSource refClkSrc, JY9511_ExteranlReferenceClockTerminal externalrefclkterminal, double referenceClockRate)
JY9511_API int | JY9511_GetDeviceInfo (JY9511_DeviceHandle hDevice, unsigned char *info)
获取设备信息
JY9511_API int | JY9511_GetDeviceID (JY9511_DeviceHandle hDevice, int *deviceID)
Obtain the board ID.
JY9511_API int | JY9511_SignalRouting (JY9511_DeviceHandle hDevice, JY9511_Signal_Source source, JY9511_Signal_Destination destination)
导出内部信号到指定端口
JY9511_API int | JY9511_DisconnectSignalRouting (JY9511_DeviceHandle hDevice, JY9511_Signal_Destination destination)
断开指定端口与内部信号的连接，复位到低电平
JY9511_API int | JY9511_GetBoardTemperature (JY9511_DeviceHandle hDevice, double *temperature)
获取板卡温度
JY9511_API int | JY9511_SetDeviceStatusLed (JY9511_DeviceHandle hDevice, bool enable, unsigned int frequency)
Control Front Panel Status Led.
JY9511_API int | JY9511_DisableAICalibration (JY9511_DeviceHandle hDevice, bool DisableCalibration)
Disable AI calibration coefficient, default false.
JY9511_API int | JY9511_DisableAILinearityCalibration (JY9511_DeviceHandle hDevice, bool DisableCalibration)
Disable AI calibration coefficient, default false.
JY9511_API int | JY9511_AI_ConfigSync (JY9511_DeviceHandle hDevice, JY9511_DeviceProperty syncMode, JY9511_Signal_Destination syncRequestRouting)
配置AI多卡同步
JY9511_API int | JY9511_AI_ParseSampleRate (double sampleRate, JY9511_AI_LPFMode filterMode, double *fMod, double *groupDelay)
获取指定采样率下的各个时钟的频率
JY9511_API int | JY9511_AI_SetLPFMode (JY9511_DeviceHandle hDevice, JY9511_AI_LPFMode filterMode)
设置低通滤波器模式
JY9511_API int | JY9511_AI_EnableChannel (JY9511_DeviceHandle hDevice, unsigned int channelCount, int *channels, JY9511_AI_Range *range, JY9511_AI_Coupling *coupling, JY9511_Terminal *terminal, bool *IEPE)
使能通道
JY9511_API int | JY9511_AI_SetSampleRate (JY9511_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
设置采样率
JY9511_API int | JY9511_AI_SetSamplesToAcquire (JY9511_DeviceHandle hDevice, unsigned int samplesToAcquire)
设置待采样数
JY9511_API int | JY9511_AI_SetSampleMode (JY9511_DeviceHandle hDevice, JY9511_AI_SampleMode mode)
设置采样模式
JY9511_API int | JY9511_AI_Commit (JY9511_DeviceHandle hDevice)
提交时钟和采样率相关配置
JY9511_API int | JY9511_AI_Start (JY9511_DeviceHandle hDevice)
开始任务
JY9511_API int | JY9511_AI_Stop (JY9511_DeviceHandle hDevice)
停止采集
JY9511_API int | JY9511_AI_ReadRawSinglePoint (JY9511_DeviceHandle hDevice, int *readValue, int channelID)
Read raw single point for each channel to user defined data buffer.
JY9511_API int | JY9511_AI_ReadSinglePoint (JY9511_DeviceHandle hDevice, double *readValue, int channelID)
获取所有已使能通道的转换输出数据（非缓冲式读取）
JY9511_API int | JY9511_AI_ReadRawData (JY9511_DeviceHandle hDevice, int *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
读取数据(原始值)
JY9511_API int | JY9511_AI_ReadData (JY9511_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
读取数据
JY9511_API int | JY9511_AI_WaitUntilDone (JY9511_DeviceHandle hDevice, int timeout, bool *done)
检查有限点采集是否已完成
JY9511_API int | JY9511_AI_CheckBufferStatus (JY9511_DeviceHandle hDevice, unsigned long long *availableSamplesCount, unsigned long long *transferedSamplesCount, bool *overflow)
获取缓冲区状态
JY9511_API int | JY9511_AI_SetStartTriggerType (JY9511_DeviceHandle hDevice, JY9511_AI_TriggerType triggerType)
设置StartTigger的触发模式
JY9511_API int | JY9511_AI_SetBesselComp (JY9511_DeviceHandle hDevice, bool enable)
设置Bessel滤波器造成的通带衰减的补偿
JY9511_API int | JY9511_AI_SetDigitalStartTrigger (JY9511_DeviceHandle hDevice, JY9511_DigitalTriggerSource triggerSource, JY9511_DigitalTriggerEdge triggerEdge)
设置StartTrigger的数字触发源
JY9511_API int | JY9511_AI_SetAnalogWindowStartTrigger (JY9511_DeviceHandle hDevice, JY9511_AnalogTriggerSource triggerSource, JY9511_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window start trigger,the triggerSource is defined by enum JY9511_AnalogTriggerSource, the triggerCondition is defined by enum JY9511_AnalogWindowCondition.
JY9511_API int | JY9511_AI_SetAnalogHysteresisStartTrigger (JY9511_DeviceHandle hDevice, JY9511_AnalogTriggerSource triggerSource, JY9511_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY9511_AnalogTriggerSource, the triggerEdge is defined by enum JY9511_AnalogTriggerEdge.
JY9511_API int | JY9511_AI_SetAnalogEdgeStartTrigger (JY9511_DeviceHandle hDevice, JY9511_AnalogTriggerSource triggerSource, JY9511_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge start trigger,the triggerSource is defined by enum JY9511_AnalogTriggerSource, the triggerEdge is defined by enum JY9511_AnalogTriggerEdge.
JY9511_API int | JY9511_AI_SetReferenceTriggerType (JY9511_DeviceHandle hDevice, JY9511_AI_TriggerType triggerType)
Set AI reference trigger type,the triggerType is defined by enum JY9511_AI_TriggerType.
JY9511_API int | JY9511_AI_SetDigitalReferenceTrigger (JY9511_DeviceHandle hDevice, JY9511_DigitalTriggerSource triggerSource, JY9511_DigitalTriggerEdge triggerEdge)
设置ReferenceTrigger的数字触发源
JY9511_API int | JY9511_AI_SetAnalogWindowReferenceTrigger (JY9511_DeviceHandle hDevice, JY9511_AnalogTriggerSource triggerSource, JY9511_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window reference trigger,the triggerSource is defined by enum JY9511_AnalogTriggerSource, the triggerCondition is defined by enum JY9511_AnalogTriggerCondition.
JY9511_API int | JY9511_AI_SetAnalogHysteresisReferenceTrigger (JY9511_DeviceHandle hDevice, JY9511_AnalogTriggerSource triggerSource, JY9511_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY9511_AnalogTriggerSource, the triggerEdge is defined by enum JY9511_AnalogTriggerEdge.
JY9511_API int | JY9511_AI_SetAnalogEdgeReferenceTrigger (JY9511_DeviceHandle hDevice, JY9511_AnalogTriggerSource triggerSource, JY9511_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge reference trigger,the triggerSource is defined by enum JY9511_AnalogTriggerSource, the triggerEdge is defined by enum JY9511_AnalogTriggerEdge.
JY9511_API int | JY9511_AI_SetPreTriggerSamples (JY9511_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set AI pretrigger samples, the samples must greater than 0.
JY9511_API int | JY9511_AI_SetReTriggerCount (JY9511_DeviceHandle hDevice, unsigned long long reTriggerCount)
设置重触发次数
JY9511_API int | JY9511_AI_SendSoftwareTrigger (JY9511_DeviceHandle hDevice, JY9511_TriggerMode triggerSel)
发送软件触发
JY9511_API int | JY9511_AI_Sync (JY9511_DeviceHandle hDevice)
启动同步。当同步模式为Independent时，立即同步PLL和ADC，不输出同步请求；当同步模式为Master时，立即同步PLL和ADC，并输出同步请求；当同步模式为Slave时，等待同步请求到达后同步PLL和ADC。应先开启Slave的同步流程，再开启Master的同步流程。
JY9511_API int | JY9511_AI_CheckSyncStatus (JY9511_DeviceHandle hDevice, bool *adcSynchronized)
获取同步状态
JY9511_API int | JY9511_AI_DetectIEPEConnection (JY9511_DeviceHandle hDevice, JY9511_IEPEConnectionStatus *buf)
检测IEPE连接状态（正常/开路/短路）。当采集任务正在运行时不要调用；执行本操作前无需调用Commit(),但执行过本操作后若要执行采集任务则必须重新调用Commit()。
JY9511_API int | JY9511_AI_ConfigSignalExport (JY9511_DeviceHandle hDevice, unsigned int routesCount, JY9511_Signal_Destination *dests, JY9511_Signal_Source *srcs)
JY9511_API int | JY9511_IdentifyTEDSChip (JY9511_DeviceHandle hDevice, int chID, unsigned long long *romID, int *totalPageCount)
识别指定通道上连接的TEDS传感器的TEDS芯片（EEPROM），以获取其型号和存储容量。
JY9511_API int | JY9511_ReadTEDSData (JY9511_DeviceHandle hDevice, int chID, unsigned long long romID, char *data, int readPageCount, int startPageIndex=0)
从指定通道上读取TEDS传感器的TEDS数据。比须在TEDS读写IO初始化之后再调用。
JY9511_API int | JY9511_AO_EnableChannel (JY9511_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion, JY9511_Terminal *terminal)
向指定通道上的TEDS传感器写入TEDS数据。比须在TEDS读写IO初始化之后再调用。
JY9511_API int | JY9511_AO_ConfigSync (JY9511_DeviceHandle hDevice, JY9511_DeviceProperty syncMode, JY9511_Signal_Destination syncRequestRouting)
配置AO多卡同步
JY9511_API int | JY9511_AO_SetUpdateRate (JY9511_DeviceHandle hDevice, double updateRate, double *actualUpdateRate)
Set AO update rate for each channel.
JY9511_API int | JY9511_AO_SetMode (JY9511_DeviceHandle hDevice, JY9511_AO_UpdateMode mode)
Set AO mode, the mode defined by enum JY9511_AO_UpdateMode.
JY9511_API int | JY9511_DisableAOCalibration (JY9511_DeviceHandle hDevice, bool DisableCalibration)
JY9511_API int | JY9511_DisableAOLinearityCalibration (JY9511_DeviceHandle hDevice, bool DisableCalibration)
JY9511_API int | JY9511_AO_SetSamplesToUpdate (JY9511_DeviceHandle hDevice, unsigned int sampleToUpdate)
Set AO samples for each channel in the finite mode.The sample range is from 1 to 32M / channelCount samples.
JY9511_API int | JY9511_AO_SetBesselComp (JY9511_DeviceHandle hDevice, bool enable)
设置Bessel滤波器造成的通带衰减的补偿
JY9511_API int | JY9511_AO_ParseSampleRate (double sampleRate, double *groupDelay)
获取指定采样率下的各个时钟的频率
JY9511_API int | JY9511_AO_Commit (JY9511_DeviceHandle hDevice)
提交时钟和采样率相关配置
JY9511_API int | JY9511_AO_Start (JY9511_DeviceHandle hDevice)
Start digital signal output.
JY9511_API int | JY9511_AO_WriteData (JY9511_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
AO writes data.The data is interleaved in the buffer the order defined by JY9511_AO_EnableChannel.
JY9511_API int | JY9511_AO_WriteRawData (JY9511_DeviceHandle hDevice, int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
AO write raw data.The data is interleaved in the buffer in channel order for multi-channel.
JY9511_API int | JY9511_AO_Stop (JY9511_DeviceHandle hDevice)
Stop analog signal output.
JY9511_API int | JY9511_AO_SetStartTriggerType (JY9511_DeviceHandle hDevice, JY9511_AO_TriggerType triggerType)
Set AO start trigger type,the triggerType is defined by enum JY9511_AO_TriggerType.
JY9511_API int | JY9511_AO_SetDigitalStartTrigger (JY9511_DeviceHandle hDevice, JY9511_DigitalTriggerSource triggerSource, JY9511_DigitalTriggerEdge triggerEdge)
Set AO digital start trigger,the triggerSource is defined by enum JY9511_DigitalTriggerSource, the triggerEdge is defined by enum JY9511_DigitalTriggerEdge.
JY9511_API int | JY9511_AO_WaitUntilDone (JY9511_DeviceHandle hDevice, bool *done, int timeOut)
Check AO finite output is complete.
JY9511_API int | JY9511_AO_CheckBufferStatus (JY9511_DeviceHandle hDevice, unsigned long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check AO task buffer status.
JY9511_API int | JY9511_AO_SendSoftTrigger (JY9511_DeviceHandle hDevice)
Send the software trigger signal.
JY9511_API int | JY9511_AO_ConfigDDS (JY9511_DeviceHandle hDevice, int channelID, double expectedFrequency, double amplitude, double offset)
Config AO DDS.
JY9511_API int | JY9511_AO_GetPLL (JY9511_DeviceHandle hDevice, double *updaterate, double *DACSampleRate, double *systemclkrate)
JY9511_API int | JY9511_AI_GetClkFreq (JY9511_DeviceHandle hDevice, double *mclkFreq, double *fMod, double *dclkFreq, double *odr)
JY9511_API int | JY9511_CI_EnableChannel (JY9511_DeviceHandle hDevice, unsigned int channel)
Enables CI channel.There are 1 counter.
JY9511_API int | JY9511_CI_SetCounterType (JY9511_DeviceHandle hDevice, unsigned int channel, JY9511_CI_MeasureType measureType)
Set CI measure type.
JY9511_API int | JY9511_CI_SetSignalReverse (JY9511_DeviceHandle hDevice, unsigned int channel, int signalReverse)
Set the Signal Reverse terminal.
JY9511_API int | JY9511_CI_SetCounterParament (JY9511_DeviceHandle hDevice, unsigned int channel, int initCount, JY9511_CountDirection countDirection)
Set CI count parameter.
JY9511_API int | JY9511_CI_SetMode (JY9511_DeviceHandle hDevice, unsigned int channel, JY9511_CI_SampleMode mode)
Set counter input mode, the mode is defined by enum JY9511_CI_SampleMode.
JY9511_API int | JY9511_CI_SetSampleClock (JY9511_DeviceHandle hDevice, unsigned int channel, JY9511_CI_SampleClock clock, JY9511_ExternalClockTerminal terminal, double rate)
Set counter input sampling clock source.
JY9511_API int | JY9511_CI_SetSamplesToAcquire (JY9511_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToAcquire)
Set samples to acquire in finite mode.The samples range is 1 to 4M.
JY9511_API int | JY9511_CI_SetEdgeCountEvent (JY9511_DeviceHandle hDevice, unsigned int channel, JY9511_CI_CounterEventSignalIdleState idleState, unsigned int threshold)
Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.
JY9511_API int | JY9511_CI_SetEdgeCountEventEx (JY9511_DeviceHandle hDevice, unsigned int channel, JY9511_CI_CounterEventSignalIdleState idleState, unsigned int threshold, bool reset)
Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.
JY9511_API int | JY9511_CI_SetPauseTriggerLevel (JY9511_DeviceHandle hDevice, unsigned int channel, bool enable, JY9511_LevelState pauseTriggerActiveLevel)
Config CI pause trigger.
JY9511_API int | JY9511_CI_SetPauseTriggerTerminal (JY9511_DeviceHandle hDevice, int channel, JY9511_InputTerminal pauseTriggerTerminal)
Set CI pause trigger terminal.
JY9511_API int | JY9511_CI_ReadSingleCountValue (JY9511_DeviceHandle hDevice, unsigned int channel, unsigned int *countValue)
Counter reads a single count value, this API supports the CI Type: JY9511_CI_EdgeCount.
JY9511_API int | JY9511_CI_ReadSingleMeasureValue (JY9511_DeviceHandle hDevice, unsigned int channel, double *measureValue1, double *measureValue2, int timeOut)
Reads a single counter measurement as follows.
JY9511_API int | JY9511_CI_ReadCountValues (JY9511_DeviceHandle hDevice, unsigned int channel, unsigned int *countValues, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the count values, this API is supprot CI Type ：JY9511_CI_EdgeCount.
JY9511_API int | JY9511_CI_ReadMeasureValues (JY9511_DeviceHandle hDevice, unsigned int channel, double *measureValues1, double *measureValues2, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the measured values, this API only support CI Type for JY9511_CI_Measure_Pulse JY9511_CI_Measure_Frequency JY9511_CI_Measure_Period for JY9511_CI_Measure_Pulse type, the measureValues1 is the Low level signal time, the measureValues2 is the Highe level signal time, the unit is s.
JY9511_API int | JY9511_CI_Start (JY9511_DeviceHandle hDevice, unsigned int channel)
Start Counter input.
JY9511_API int | JY9511_CI_Stop (JY9511_DeviceHandle hDevice, unsigned int channel)
Stop Counter input.
JY9511_API int | JY9511_CI_CheckBufferStatus (JY9511_DeviceHandle hDevice, unsigned int channel, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CI task buffer status.
JY9511_API int | JY9511_CI_SetTimeBase (JY9511_DeviceHandle hDevice, unsigned int channel, JY9511_CountTimeBase timebaseSrc, JY9511_InputTerminal externalTimebaseTerminal, double externalTimebaseFreq, double *actualTimebaseFreq)
Set CI timebase source.
JY9511_API int | JY9511_CI_SetSourceTerminal (JY9511_DeviceHandle hDevice, int channel, JY9511_InputTerminal sourceTerminal)
Set source terminal.
JY9511_API int | JY9511_CI_SetGateTerminal (JY9511_DeviceHandle hDevice, int channel, JY9511_InputTerminal gateTerminal)
Set gate terminal.
JY9511_API int | JY9511_CI_SendSoftTrigger (JY9511_DeviceHandle hDevice, int channel)
Send the software trigger signal for CI.
JY9511_API int | JY9511_CI_SetStartingEdge (JY9511_DeviceHandle hDevice, unsigned int channel, JY9511_CI_StartingEdge startingEdge)
Set start measure edge.
JY9511_API int | JY9511_CI_SetFirstSampleClock (JY9511_DeviceHandle hDevice, unsigned int channel, bool ignore)
Set first sample clock is ignore.
JY9511_API int | JY9511_CI_SetStartTriggerType (JY9511_DeviceHandle hDevice, int channel, JY9511_CI_TriggerType triggerTyp)
Set CI start trigger type,the triggerType is defined by enum JY9511_CI_TriggerType.
JY9511_API int | JY9511_CI_SetDigitalStartTrigger (JY9511_DeviceHandle hDevice, int channel, JY9511_DigitalTriggerSource triggerSource, JY9511_DigitalTriggerEdge triggerEdge)
Set CI digital start trigger.the triggerSource is defined by enum JY9511_DigitalTriggerSource, the triggerEdge is defined by enum JY9511_DigitalTriggerEdge.

Typedef Documentation

◆ JY9511_DeviceHandle

typedef void* JY9511_DeviceHandle

Windows.

Linux

Enumeration Type Documentation

◆ JY9511_AI_Coupling

enum JY9511_AI_Coupling
Enumerator
JY9511_AC
JY9511_DC

◆ JY9511_AI_LPFMode

enum JY9511_AI_LPFMode
Enumerator
JY9511_AI_LPF_Normal | Normal Mode. It has 0.4Fs bandwidth, medium latency, and a maximum sample rate of 256kSa/s
JY9511_AI_LPF_WideBandwidth | Wide Bandwidth Mode. It has 0.4535Fs bandwidth, high latency, and a maximum sample rate of 128kSa/s

◆ JY9511_AI_Range

enum JY9511_AI_Range
Enumerator
JY9511_AI_Range_0p3125V
JY9511_AI_Range_0p625V
JY9511_AI_Range_1p25V
JY9511_AI_Range_2p5V
JY9511_AI_Range_5V
JY9511_AI_Range_10V
JY9511_AI_Range_25V
JY9511_AI_Range_50V

◆ JY9511_AI_SampleMode

enum JY9511_AI_SampleMode
Enumerator
JY9511_AI_Finite
JY9511_AI_Continuous
JY9511_AI_Single

◆ JY9511_AI_TriggerType

enum JY9511_AI_TriggerType
Enumerator
JY9511_AI_Immediately
JY9511_AI_Digital
JY9511_AI_Software
JY9511_AI_Analog

◆ JY9511_AnalogTriggerEdge

enum JY9511_AnalogTriggerEdge
Enumerator
JY9511_RisingSlope | Rsing edge for Analog trigger.
JY9511_FallingSlope | Falling edge for Analog trigger.

◆ JY9511_AnalogTriggerSource

enum JY9511_AnalogTriggerSource
Enumerator
JY9511_Channel_0 | AI Channel 0 as analog trigger source.
JY9511_Channel_1 | AI Channel 1 as analog trigger source.
JY9511_Channel_2 | AI Channel 2 as analog trigger source.
JY9511_Channel_3 | AI Channel 3 as analog trigger source.

◆ JY9511_AnalogWindowCondition

enum JY9511_AnalogWindowCondition
Enumerator
JY9511_Entering | Analog Window trigger condition is Entering.
JY9511_Leaving | Analog Window trigger condition is Leaving.

◆ JY9511_AO_Range

enum JY9511_AO_Range
Enumerator
JY9511_AO_Range_0p316V
JY9511_AO_Range_1V
JY9511_AO_Range_3p16V
JY9511_AO_Range_10V

◆ JY9511_AO_TriggerType

enum JY9511_AO_TriggerType
Enumerator
JY9511_AO_Immediately
JY9511_AO_Digital
JY9511_AO_Software

◆ JY9511_AO_UpdateMode

enum JY9511_AO_UpdateMode
Enumerator
JY9511_AO_Finite | AO Finite mode.
JY9511_AO_ContinuousWrapping | AO ContinuousWrapping mode.
JY9511_AO_ContinuousNoWrapping | AO ContinuousNoWrapping mode.
JY9511_AO_DDS | AO DDS mode.

◆ JY9511_CI_CounterEventSignalIdleState

enum JY9511_CI_CounterEventSignalIdleState
Enumerator
JY9511_CI_CounterEventSignalIdleState_Low
JY9511_CI_CounterEventSignalIdleState_High

◆ JY9511_CI_MeasureType

enum JY9511_CI_MeasureType
Enumerator
JY9511_CI_EdgeCount
JY9511_CI_Measure_FrequencyOrPeriod
JY9511_CI_Measure_PulseWidth
JY9511_CI_Measure_SemiPeriod

◆ JY9511_CI_SampleClock

enum JY9511_CI_SampleClock
Enumerator
JY9511_CI_ImplicitClock
JY9511_CI_InternalClock
JY9511_CI_ExternalClock

◆ JY9511_CI_SampleMode

enum JY9511_CI_SampleMode
Enumerator
JY9511_CI_Finite
JY9511_CI_Continuous
JY9511_CI_Single

◆ JY9511_CI_StartingEdge

enum JY9511_CI_StartingEdge
Enumerator
JY9511_RisingEdge
JY9511_FallingEdge
JY9511_AnyEdge

◆ JY9511_CI_TriggerType

enum JY9511_CI_TriggerType
Enumerator
JY9511_CIO_Immediately
JY9511_CIO_Digital
JY9511_CIO_Soft

◆ JY9511_CountDirection

enum JY9511_CountDirection
Enumerator
JY9511_CI_Count_Up
JY9511_CI_Count_Down
JY9511_CI_Count_External

◆ JY9511_CountTimeBase

enum JY9511_CountTimeBase
Enumerator
JY9511_Internal_Timebase_100M
JY9511_Internal_Timebase_5M
JY9511_Internal_Timebase_100K
JY9511_External_Timebase
JY9511_MCLK_Timebase

◆ JY9511_DeviceProperty

enum JY9511_DeviceProperty
Enumerator
JY9511_Independent | Device as independent.
JY9511_MASTER | Device as master.
JY9511_SLAVE | Device as slave.

◆ JY9511_DigitalTriggerEdge

enum JY9511_DigitalTriggerEdge
Enumerator
JY9511_Rising
JY9511_Falling

◆ JY9511_DigitalTriggerSource

enum JY9511_DigitalTriggerSource
Enumerator
JY9511_PFI0 | PFI_0 as the digital trigger source.
JY9511_PXI_Trig0 | PXI_Trig0 as the digital trigger source.
JY9511_PXI_Trig1 | PXI_Trig1 as the digital trigger source.
JY9511_PXI_Trig2 | PXI_Trig2 as the digital trigger source.
JY9511_PXI_Trig3 | PXI_Trig3 as the digital trigger source.
JY9511_PXI_Trig4 | PXI_Trig4 as the digital trigger source.
JY9511_PXI_Trig5 | PXI_Trig5 as the digital trigger source.
JY9511_PXI_Trig6 | PXI_Trig6 as the digital trigger source.
JY9511_PXI_Trig7 | PXI_Trig7 as the digital trigger source.
JY9511_Inter_AI_StartTrig | AI_StartTrig as the digital trigger source.
JY9511_Inter_AI_ReferenceTrig | AI_ReferenceTrig as the digital trigger source.
JY9511_Inter_AO_StartTrig | AO_StartTrig as the digital trigger source.
JY9511_Inter_Counter_0_StartTrig |

◆ JY9511_ExteranlReferenceClockTerminal

enum JY9511_ExteranlReferenceClockTerminal
Enumerator
JY9511_Clock_In
JY9511_PXIe_Clk100

◆ JY9511_ExternalClockTerminal

enum JY9511_ExternalClockTerminal
Enumerator
JY9511_Clock_PXI_Trig_0
JY9511_Clock_PXI_Trig_1
JY9511_Clock_PXI_Trig_2
JY9511_Clock_PXI_Trig_3
JY9511_Clock_PXI_Trig_4
JY9511_Clock_PXI_Trig_5
JY9511_Clock_PXI_Trig_6
JY9511_Clock_PXI_Trig_7

◆ JY9511_IEPEConnectionStatus

enum JY9511_IEPEConnectionStatus
Enumerator
JY9511_IEPEConnection_Normal
JY9511_IEPEConnection_Open
JY9511_IEPEConnection_Short

◆ JY9511_InputTerminal

enum JY9511_InputTerminal
Enumerator
JY9511_PFI0_Input
JY9511_PXI_Trig0_Input
JY9511_PXI_Trig1_Input
JY9511_PXI_Trig2_Input
JY9511_PXI_Trig3_Input
JY9511_PXI_Trig4_Input
JY9511_PXI_Trig5_Input
JY9511_PXI_Trig6_Input
JY9511_PXI_Trig7_Input
JY9511_AI_SampleClock_Input
JY9511_AO_SampleClock_Input
JY9511_CI_100MHz_Input
JY9511_CI_5MHz_Input
JY9511_CI_100kHz_Input
JY9511_AI_MCLK_Input

◆ JY9511_LevelState

enum JY9511_LevelState
Enumerator
JY9511_LowLevel
JY9511_HighLevel

◆ JY9511_ReferenceClockSource

enum JY9511_ReferenceClockSource
Enumerator
JY9511_Internal
JY9511_External

◆ JY9511_Signal_Destination

enum JY9511_Signal_Destination
Enumerator
JY9511_PFI0_OUT | PFI0 as the signal desition to rout.
JY9511_PXITrig0_OUT | PXITrig0 as the signal desition to rout.
JY9511_PXITrig1_OUT | PXITrig1 as the signal desition to rout.
JY9511_PXITrig2_OUT | PXITrig2 as the signal desition to rout.
JY9511_PXITrig3_OUT | PXITrig3 as the signal desition to rout.
JY9511_PXITrig4_OUT | PXITrig4 as the signal desition to rout.
JY9511_PXITrig5_OUT | PXITrig5 as the signal desition to rout.
JY9511_PXITrig6_OUT | PXITrig6 as the signal desition to rout.
JY9511_PXITrig7_OUT | PXITrig7 as the signal desition to rout.

◆ JY9511_Signal_Source

enum JY9511_Signal_Source
Enumerator
JY9511_Signal_PFI_0 | PFI0 as the source signal to rout.
JY9511_Signal_PXI_Trig_0 | PXI_Trig0 as the source signal to rout.
JY9511_Signal_PXI_Trig_1 | PXI_Trig1 as the source signal to rout.
JY9511_Signal_PXI_Trig_2 | PXI_Trig2 as the source signal to rout.
JY9511_Signal_PXI_Trig_3 | PXI_Trig3 as the source signal to rout.
JY9511_Signal_PXI_Trig_4 | PXI_Trig4 as the source signal to rout.
JY9511_Signal_PXI_Trig_5 | PXI_Trig5 as the source signal to rout.
JY9511_Signal_PXI_Trig_6 | PXI_Trig6 as the source signal to rout.
JY9511_Signal_PXI_Trig_7 | PXI_Trig7 as the source signal to rout.
JY9511_AI_StartTrig | AI_StartTrig as the source signal to rout.
JY9511_AI_ReferenceTrig | AI_ReferenceTrig as the source signal to rout.
JY9511_AO_StartTrig | AI_StartTrig as the source signal to rout.
JY9511_Signal_CI_0_StartTrig |
JY9511_Signal_CI_0_SampleClock |
JY9511_Signa_Counter_0_EventOut |

◆ JY9511_Terminal

enum JY9511_Terminal
Enumerator
JY9511_PseudoDifference
JY9511_Difference

◆ JY9511_TriggerMode

enum JY9511_TriggerMode
Enumerator
JY9511_StartTrigger | Start trigger mode.
JY9511_ReferenceTrigger | Reference trigger mode.

Function Documentation

◆ JY9511_AI_CheckBufferStatus()

JY9511_API int JY9511_AI_CheckBufferStatus | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned long long * | availableSamplesCount,
 |  | unsigned long long * | transferedSamplesCount,
 |  | bool * | overflow )

获取缓冲区状态

Parameters
hDevice | 板卡句柄
availableSamplesCount | 缓冲区已有的Sample的数量
overflow | 是否发生溢出
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_CheckSyncStatus()

JY9511_API int JY9511_AI_CheckSyncStatus | ( | JY9511_DeviceHandle | hDevice,
 |  | bool * | adcSynchronized )

获取同步状态

Parameters
hDevice | 板卡句柄
adcSynchronized | ADC已同步
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_Commit()

JY9511_API int JY9511_AI_Commit ( JY9511_DeviceHandle hDevice )

提交时钟和采样率相关配置

Parameters
hDevice 板卡句柄
Returns
成功：0 , 失败：!=0

◆ JY9511_AI_ConfigSignalExport()

JY9511_API int JY9511_AI_ConfigSignalExport | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | routesCount,
 |  | JY9511_Signal_Destination * | dests,
 |  | JY9511_Signal_Source * | srcs )

◆ JY9511_AI_ConfigSync()

JY9511_API int JY9511_AI_ConfigSync | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_DeviceProperty | syncMode,
 |  | JY9511_Signal_Destination | syncRequestRouting )

配置AI多卡同步

Parameters
hDevice | 板卡句柄
syncMode | 同步模式
syncRequestRouting | 同步请求路由路径
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_DetectIEPEConnection()

JY9511_API int JY9511_AI_DetectIEPEConnection | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_IEPEConnectionStatus * | buf )

检测IEPE连接状态（正常/开路/短路）。当采集任务正在运行时不要调用；执行本操作前无需调用Commit(),但执行过本操作后若要执行采集任务则必须重新调用Commit()。

Parameters
hDevice | 板卡句柄
buf | 返回各通道的IEPE开路/短路检测结果

◆ JY9511_AI_EnableChannel()

JY9511_API int JY9511_AI_EnableChannel | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | int * | channels,
 |  | JY9511_AI_Range * | range,
 |  | JY9511_AI_Coupling * | coupling,
 |  | JY9511_Terminal * | terminal,
 |  | bool * | IEPE )

使能通道

Parameters
hDevice | 板卡句柄
chCnt | 要使能的通道的数量
chID | 要使能的通道的物理号
range | 输入电压范围
coupling | 输入耦合方式
IEPE | 是否使能IEPE
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_GetClkFreq()

JY9511_API int JY9511_AI_GetClkFreq | ( | JY9511_DeviceHandle | hDevice,
 |  | double * | mclkFreq,
 |  | double * | fMod,
 |  | double * | dclkFreq,
 |  | double * | odr )

◆ JY9511_AI_ParseSampleRate()

JY9511_API int JY9511_AI_ParseSampleRate | ( | double | sampleRate,
 |  | JY9511_AI_LPFMode | filterMode,
 |  | double * | fMod,
 |  | double * | groupDelay )

获取指定采样率下的各个时钟的频率

Parameters
sampleRate | 采样率
filterMode | 滤波器模式
fMod | adc调制器频率
groupDelay | 总的群延迟，单位us
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_ReadData()

JY9511_API int JY9511_AI_ReadData | ( | JY9511_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength )

读取数据

Parameters
hDevice | 板卡句柄
dataBuffer | 返回采集数据的工程值（电压，单位V）
dataLength | 要读取的数据长度
timeout | 读取数据超时时间(ms)，为-1时永不超时
actualReadLength | 返回实际读取到的数据长度
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_ReadRawData()

JY9511_API int JY9511_AI_ReadRawData | ( | JY9511_DeviceHandle | hDevice,
 |  | int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength )

读取数据(原始值)

Parameters
hDevice | 板卡句柄
dataBuffer | 返回采集数据原始值
dataLength | 要读取的数据长度
timeout | 读取数据超时时间(ms)，为-1时永不超时
actualReadLength | 返回实际读取到的数据长度
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_ReadRawSinglePoint()

JY9511_API int JY9511_AI_ReadRawSinglePoint | ( | JY9511_DeviceHandle | hDevice,
 |  | int * | readValue,
 |  | int | channelID )

Read raw single point for each channel to user defined data buffer.

Parameters
hDevice | device handle
readValue | user buffer,the size of readValue must be greater than or equal to channelCount.
channelID | read the specified channelID. when the channelID is -1, read all enabled channels value.
Returns
0 if success or other error code

◆ JY9511_AI_ReadSinglePoint()

JY9511_API int JY9511_AI_ReadSinglePoint | ( | JY9511_DeviceHandle | hDevice,
 |  | double * | readValue,
 |  | int | channelID )

获取所有已使能通道的转换输出数据（非缓冲式读取）

Parameters
hDevice | 板卡句柄
dataBuffer | 返回转换输出数据（电压，单位V）
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_SendSoftwareTrigger()

JY9511_API int JY9511_AI_SendSoftwareTrigger | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_TriggerMode | triggerSel )

发送软件触发

Parameters
hDevice | 板卡句柄
triggerSel | 选择要作用的触发
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_SetAnalogEdgeReferenceTrigger()

JY9511_API int JY9511_AI_SetAnalogEdgeReferenceTrigger | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_AnalogTriggerSource | triggerSource,
 |  | JY9511_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold )

Set AI analog edge reference trigger,the triggerSource is defined by enum JY9511_AnalogTriggerSource, the triggerEdge is defined by enum JY9511_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerCondition | AI analog trigger conditions
threshold | threshold
Returns
0 if success or other error code

◆ JY9511_AI_SetAnalogEdgeStartTrigger()

JY9511_API int JY9511_AI_SetAnalogEdgeStartTrigger | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_AnalogTriggerSource | triggerSource,
 |  | JY9511_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold )

Set AI analog edge start trigger,the triggerSource is defined by enum JY9511_AnalogTriggerSource, the triggerEdge is defined by enum JY9511_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY9511_AI_SetAnalogHysteresisReferenceTrigger()

JY9511_API int JY9511_AI_SetAnalogHysteresisReferenceTrigger | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_AnalogTriggerSource | triggerSource,
 |  | JY9511_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY9511_AnalogTriggerSource, the triggerEdge is defined by enum JY9511_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY9511_AI_SetAnalogHysteresisStartTrigger()

JY9511_API int JY9511_AI_SetAnalogHysteresisStartTrigger | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_AnalogTriggerSource | triggerSource,
 |  | JY9511_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY9511_AnalogTriggerSource, the triggerEdge is defined by enum JY9511_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY9511_AI_SetAnalogWindowReferenceTrigger()

JY9511_API int JY9511_AI_SetAnalogWindowReferenceTrigger | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_AnalogTriggerSource | triggerSource,
 |  | JY9511_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog window reference trigger,the triggerSource is defined by enum JY9511_AnalogTriggerSource, the triggerCondition is defined by enum JY9511_AnalogTriggerCondition.

Parameters
hDevice | device handle
triggerSource | AI reference trigger source,0-16<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY9511_AI_SetAnalogWindowStartTrigger()

JY9511_API int JY9511_AI_SetAnalogWindowStartTrigger | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_AnalogTriggerSource | triggerSource,
 |  | JY9511_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog window start trigger,the triggerSource is defined by enum JY9511_AnalogTriggerSource, the triggerCondition is defined by enum JY9511_AnalogWindowCondition.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY9511_AI_SetBesselComp()

JY9511_API int JY9511_AI_SetBesselComp | ( | JY9511_DeviceHandle | hDevice,
 |  | bool | enable )

设置Bessel滤波器造成的通带衰减的补偿

Parameters
hDevice | 板卡句柄
enable | 是否使能。默认使能。

◆ JY9511_AI_SetDigitalReferenceTrigger()

JY9511_API int JY9511_AI_SetDigitalReferenceTrigger | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_DigitalTriggerSource | triggerSource,
 |  | JY9511_DigitalTriggerEdge | triggerEdge )

设置ReferenceTrigger的数字触发源

Parameters
hDevice | 板卡句柄
triggerSource | 数字触发源通道选择
triggerEdge | 数字触发源触发条件选择
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_SetDigitalStartTrigger()

JY9511_API int JY9511_AI_SetDigitalStartTrigger | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_DigitalTriggerSource | triggerSource,
 |  | JY9511_DigitalTriggerEdge | triggerEdge )

设置StartTrigger的数字触发源

Parameters
hDevice | 板卡句柄
triggerSource | 数字触发源通道选择
triggerEdge | 数字触发源触发条件选择
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_SetLPFMode()

JY9511_API int JY9511_AI_SetLPFMode | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_AI_LPFMode | filterMode )

设置低通滤波器模式

Parameters
hDevice | 板卡句柄
filterMode | 低通滤波器模式

◆ JY9511_AI_SetPreTriggerSamples()

JY9511_API int JY9511_AI_SetPreTriggerSamples | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples )

Set AI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | AI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY9511_AI_SetReferenceTriggerType()

JY9511_API int JY9511_AI_SetReferenceTriggerType | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_AI_TriggerType | triggerType )

Set AI reference trigger type,the triggerType is defined by enum JY9511_AI_TriggerType.

Parameters
hDevice | device handle
triggerType | AI reference trigger type.Options: immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY9511_AI_SetReTriggerCount()

JY9511_API int JY9511_AI_SetReTriggerCount | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned long long | reTriggerCount )

设置重触发次数

Parameters
hDevice | 板卡句柄
reTriggerCount | 重触发次数
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_SetSampleMode()

JY9511_API int JY9511_AI_SetSampleMode | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_AI_SampleMode | mode )

设置采样模式

Parameters
hDevice | 板卡句柄
mode | 采样模式
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_SetSampleRate()

JY9511_API int JY9511_AI_SetSampleRate | ( | JY9511_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate )

设置采样率

Parameters
hDevice | 板卡句柄
sampleRate | 要设置的采样率
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_SetSamplesToAcquire()

JY9511_API int JY9511_AI_SetSamplesToAcquire | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | samplesToAcquire )

设置待采样数

Parameters
hDevice | 板卡句柄
samplesToAcquire | 待采样数，即每个通道上要采集的样点数
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_SetStartTriggerType()

JY9511_API int JY9511_AI_SetStartTriggerType | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_AI_TriggerType | triggerType )

设置StartTigger的触发模式

Parameters
hDevice | 板卡句柄
triggerType | 开始触发的工作模式(Immediate/Digital/Analog/Software)
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_Start()

JY9511_API int JY9511_AI_Start ( JY9511_DeviceHandle hDevice )

开始任务

Parameters
hDevice 板卡句柄
Returns
成功：0 , 失败：!=0

◆ JY9511_AI_Stop()

JY9511_API int JY9511_AI_Stop ( JY9511_DeviceHandle hDevice )

停止采集

Parameters
hDevice 板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_Sync()

JY9511_API int JY9511_AI_Sync ( JY9511_DeviceHandle hDevice )

启动同步。当同步模式为Independent时，立即同步PLL和ADC，不输出同步请求；当同步模式为Master时，立即同步PLL和ADC，并输出同步请求；当同步模式为Slave时，等待同步请求到达后同步PLL和ADC。应先开启Slave的同步流程，再开启Master的同步流程。

Parameters
hDevice 板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9511_AI_WaitUntilDone()

JY9511_API int JY9511_AI_WaitUntilDone | ( | JY9511_DeviceHandle | hDevice,
 |  | int | timeout,
 |  | bool * | done )

检查有限点采集是否已完成

Parameters
hDevice | 板卡句柄
timeout | 超时时间(ms)，为-1时永不超时
done | 返回有限点采集是否已完成(true/false)
Returns
0：无错误；其它：发生错误

◆ JY9511_AO_CheckBufferStatus()

JY9511_API int JY9511_AO_CheckBufferStatus | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check AO task buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of AO samples per channel user can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY9511_AO_Commit()

JY9511_API int JY9511_AO_Commit ( JY9511_DeviceHandle hDevice )

提交时钟和采样率相关配置

Parameters
hDevice 板卡句柄
Returns
成功：0 , 失败：!=0

◆ JY9511_AO_ConfigDDS()

JY9511_API int JY9511_AO_ConfigDDS | ( | JY9511_DeviceHandle | hDevice,
 |  | int | channelID,
 |  | double | expectedFrequency,
 |  | double | amplitude,
 |  | double | offset )

Config AO DDS.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9511_AO_ConfigSync()

JY9511_API int JY9511_AO_ConfigSync | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_DeviceProperty | syncMode,
 |  | JY9511_Signal_Destination | syncRequestRouting )

配置AO多卡同步

Parameters
hDevice | 板卡句柄
syncMode | 同步模式
syncRequestRouting | 同步请求路由路径
Returns
0：无错误；其它：发生错误

◆ JY9511_AO_EnableChannel()

JY9511_API int JY9511_AO_EnableChannel | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion,
 |  | JY9511_Terminal * | terminal )

向指定通道上的TEDS传感器写入TEDS数据。比须在TEDS读写IO初始化之后再调用。

Parameters
hDevice | 板卡句柄
chID | 要执行TEDS写入的通道
romID | EEPROM芯片的64-bit ROM ID。通过 JY9511_IdetifyTEDSDevice() 获取该ID。
data | 数据缓存
writePageCount | 要写入的页的数量。固定从第1页开始写入，每页TEDS数据的长度固定为32bytes，总写入长度不得超过TEDS器件内存的总页数。通过过 JY9511T_IdetifyTEDSDevice() 获取TEDS内存器件的总页数。
Returns
成功：0 , 失败：!=0

Enables AO channels.

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
Returns
0 if success or other error code

◆ JY9511_AO_GetPLL()

JY9511_API int JY9511_AO_GetPLL | ( | JY9511_DeviceHandle | hDevice,
 |  | double * | updaterate,
 |  | double * | DACSampleRate,
 |  | double * | systemclkrate )

◆ JY9511_AO_ParseSampleRate()

JY9511_API int JY9511_AO_ParseSampleRate | ( | double | sampleRate,
 |  | double * | groupDelay )

获取指定采样率下的各个时钟的频率

Parameters
sampleRate | 更新率
groupDelay | 总的群延迟，单位us
Returns
0：无错误；其它：发生错误

◆ JY9511_AO_SendSoftTrigger()

JY9511_API int JY9511_AO_SendSoftTrigger ( JY9511_DeviceHandle hDevice )

Send the software trigger signal.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9511_AO_SetBesselComp()

JY9511_API int JY9511_AO_SetBesselComp | ( | JY9511_DeviceHandle | hDevice,
 |  | bool | enable )

设置Bessel滤波器造成的通带衰减的补偿

Parameters
hDevice | 板卡句柄
enable | 是否使能。默认使能。

◆ JY9511_AO_SetDigitalStartTrigger()

JY9511_API int JY9511_AO_SetDigitalStartTrigger | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_DigitalTriggerSource | triggerSource,
 |  | JY9511_DigitalTriggerEdge | triggerEdge )

Set AO digital start trigger,the triggerSource is defined by enum JY9511_DigitalTriggerSource, the triggerEdge is defined by enum JY9511_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AO digital start trigger source
triggerEdge | AO digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY9511_AO_SetMode()

JY9511_API int JY9511_AO_SetMode | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_AO_UpdateMode | mode )

Set AO mode, the mode defined by enum JY9511_AO_UpdateMode.

Parameters
hDevice | device handle
mode | AO output mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY9511_AO_SetSamplesToUpdate()

JY9511_API int JY9511_AO_SetSamplesToUpdate | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | sampleToUpdate )

Set AO samples for each channel in the finite mode.The sample range is from 1 to 32M / channelCount samples.

Parameters
hDevice | device handle
sampleToUpdate | number of AO samples per channel. Data range:1 to 32M / channelCount samples.
Returns
0 if success or other error code

◆ JY9511_AO_SetStartTriggerType()

JY9511_API int JY9511_AO_SetStartTriggerType | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_AO_TriggerType | triggerType )

Set AO start trigger type,the triggerType is defined by enum JY9511_AO_TriggerType.

Parameters
hDevice | device handle
triggerType | AO start trigger type. Options: immediate trigger, software trigger, digital trigger .
Returns
0 if success or other error code

◆ JY9511_AO_SetUpdateRate()

JY9511_API int JY9511_AO_SetUpdateRate | ( | JY9511_DeviceHandle | hDevice,
 |  | double | updateRate,
 |  | double * | actualUpdateRate )

Set AO update rate for each channel.

Parameters
hDevice | device handle
updateRate | AO update rate to be set per channel
actualUpdateRate | AO update rate actually set. The actual update rate set by this device,which may be different from the desired updata rate.
Returns
0 if success or other error code

◆ JY9511_AO_Start()

JY9511_API int JY9511_AO_Start ( JY9511_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9511_AO_Stop()

JY9511_API int JY9511_AO_Stop ( JY9511_DeviceHandle hDevice )

Stop analog signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9511_AO_WaitUntilDone()

JY9511_API int JY9511_AO_WaitUntilDone | ( | JY9511_DeviceHandle | hDevice,
 |  | bool * | done,
 |  | int | timeOut )

Check AO finite output is complete.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
timeOut | timeout time in microsecond, this parament not valid in current version
Returns
0 if success or other error code

◆ JY9511_AO_WriteData()

JY9511_API int JY9511_AO_WriteData | ( | JY9511_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength )

AO writes data.The data is interleaved in the buffer the order defined by JY9511_AO_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer of output data.The buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JY9511_AO_WriteRawData()

JY9511_API int JY9511_AO_WriteRawData | ( | JY9511_DeviceHandle | hDevice,
 |  | int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength )

AO write raw data.The data is interleaved in the buffer in channel order for multi-channel.

Parameters
hDevice | device handle
dataBuffer | user buffer, the buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JY9511_CI_CheckBufferStatus()

JY9511_API int JY9511_CI_CheckBufferStatus | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check CI task buffer status.

Parameters
hDevice | device handle
channel | counter input channel
avaliableSamples | number of samples that the device buffer can read
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY9511_CI_EnableChannel()

JY9511_API int JY9511_CI_EnableChannel | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Enables CI channel.There are 1 counter.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY9511_CI_ReadCountValues()

JY9511_API int JY9511_CI_ReadCountValues | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValues,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Counter reads the count values, this API is supprot CI Type ：JY9511_CI_EdgeCount.

Parameters
hDevice | device handle
channel | counter input channel
countValues | user buffer,the buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | timeout time in microsecond
actualReadLength | return value, the actual length of the data read.
Returns
0 if success or other error code

◆ JY9511_CI_ReadMeasureValues()

JY9511_API int JY9511_CI_ReadMeasureValues | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValues1,
 |  | double * | measureValues2,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Counter reads the measured values, this API only support CI Type for JY9511_CI_Measure_Pulse JY9511_CI_Measure_Frequency JY9511_CI_Measure_Period for JY9511_CI_Measure_Pulse type, the measureValues1 is the Low level signal time, the measureValues2 is the Highe level signal time, the unit is s.

for JY9511_CI_Measure_Frequency type, the measureValues1 is signal frequency, the unit is Hz. for JY9511_CI_Measure_Period type, the measureValues2 is signal period, the unit is s. The JY9511_CI_Measure_Period type and JY9511_CI_Measure_Frequency type is same time measurement, user need to read both measurements simultaneously.

Parameters
hDevice | device handle
channel | counter input channel
measureValues | user buffer.The buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | measure timeout time in microsecond
actualReadLength | reture the actual length of the data read
Returns
0 if success or other error code

◆ JY9511_CI_ReadSingleCountValue()

JY9511_API int JY9511_CI_ReadSingleCountValue | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValue )

Counter reads a single count value, this API supports the CI Type: JY9511_CI_EdgeCount.

Parameters
hDevice | device handle
channel | counter input channel. An integer counter number, eg, 0 for counter 0.
countValue | return the current count value of counter.
Returns
0 if success or other error code

◆ JY9511_CI_ReadSingleMeasureValue()

JY9511_API int JY9511_CI_ReadSingleMeasureValue | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValue1,
 |  | double * | measureValue2,
 |  | int | timeOut )

Reads a single counter measurement as follows.

for JY9511_CI_Measure_Pulse type, measureValues1 is the Low level signal time, the measureValues2 is the high level signal time, the unit is in second. for JY9511_CI_Measure_Frequency type, measureValues1 is signal frequency in Hz, measureValue2 has no meaning. for JY9511_CI_Measure_Period type, measureValues2 is signal period in second; measureValue1 has no meaning.

Parameters
hDevice | device handle
channel | Counter input channel
measureValue1 | current measure value of counter
measureValue2 | current measure value of counter
timeOut | timeout time in microsecond
Returns
0 if success or other error code

◆ JY9511_CI_SendSoftTrigger()

JY9511_API int JY9511_CI_SendSoftTrigger | ( | JY9511_DeviceHandle | hDevice,
 |  | int | channel )

Send the software trigger signal for CI.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY9511_CI_SetCounterParament()

JY9511_API int JY9511_CI_SetCounterParament | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | initCount,
 |  | JY9511_CountDirection | countDirection )

Set CI count parameter.

Parameters
hDevice | device handle
channel | counter input channel
initCount | counter initial value
countDirection | counting direction of the counter defined by enum JY9511_CountDirection
Returns
0 if success or other error code

◆ JY9511_CI_SetCounterType()

JY9511_API int JY9511_CI_SetCounterType | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY9511_CI_MeasureType | measureType )

Set CI measure type.

Parameters
hDevice | device handle
channel | counter input channel
measureType | measure type. defined by enum JY9511_CI_MeasureType
Returns
0 if success or other error code

◆ JY9511_CI_SetDigitalStartTrigger()

JY9511_API int JY9511_CI_SetDigitalStartTrigger | ( | JY9511_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY9511_DigitalTriggerSource | triggerSource,
 |  | JY9511_DigitalTriggerEdge | triggerEdge )

Set CI digital start trigger.the triggerSource is defined by enum JY9511_DigitalTriggerSource, the triggerEdge is defined by enum JY9511_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter input channel
triggerSource | CI digital start trigger source
triggerEdge | CI digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY9511_CI_SetEdgeCountEvent()

JY9511_API int JY9511_CI_SetEdgeCountEvent | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY9511_CI_CounterEventSignalIdleState | idleState,
 |  | unsigned int | threshold )

Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.

Parameters
hDevice | device handle
channel | counter input channel
idleState | output terminal idle state
threshold | threshold
Returns
0 if success or other error code

◆ JY9511_CI_SetEdgeCountEventEx()

JY9511_API int JY9511_CI_SetEdgeCountEventEx | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY9511_CI_CounterEventSignalIdleState | idleState,
 |  | unsigned int | threshold,
 |  | bool | reset )

Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.

Parameters
hDevice | device handle
channel | counter input channel
idleState | output terminal idle state
threshold | threshold
reset | reset count value to initialCount if ture. if false, the counter continuous count.
Returns
0 if success or other error code

◆ JY9511_CI_SetFirstSampleClock()

JY9511_API int JY9511_CI_SetFirstSampleClock | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | ignore )

Set first sample clock is ignore.

Parameters
hDevice | device handle
channel | counter input channel
ignore | is ignore first sample clock
Returns
0 if success or other error code

◆ JY9511_CI_SetGateTerminal()

JY9511_API int JY9511_CI_SetGateTerminal | ( | JY9511_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY9511_InputTerminal | gateTerminal )

Set gate terminal.

Parameters
hDevice | device handle
channel | counter output channel
gateTerminal | gate terminal
Returns
0 if success or other error code

◆ JY9511_CI_SetMode()

JY9511_API int JY9511_CI_SetMode | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY9511_CI_SampleMode | mode )

Set counter input mode, the mode is defined by enum JY9511_CI_SampleMode.

Parameters
hDevice | device handle
channel | counter input channel
mode | counter input mode, Options: single,finite,continuous.
Returns
0 if success or other error code

◆ JY9511_CI_SetPauseTriggerLevel()

JY9511_API int JY9511_CI_SetPauseTriggerLevel | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JY9511_LevelState | pauseTriggerActiveLevel )

Config CI pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JY9511_CI_SetPauseTriggerTerminal()

JY9511_API int JY9511_CI_SetPauseTriggerTerminal | ( | JY9511_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY9511_InputTerminal | pauseTriggerTerminal )

Set CI pause trigger terminal.

Parameters
hDevice | device handle
channel | counter output channel
pauseTriggerTerminal | pause Trigger Terminal
Returns
0 if success or other error code

◆ JY9511_CI_SetSampleClock()

JY9511_API int JY9511_CI_SetSampleClock | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY9511_CI_SampleClock | clock,
 |  | JY9511_ExternalClockTerminal | terminal,
 |  | double | rate )

Set counter input sampling clock source.

If the clockType is internal, user need to define sampleRate, if the clockType is JY9511_CI_ImplicitClk, the sample rate determine by the measuer signal.

Parameters
hDevice | device handle
channel | counter input channel
clock | counter input clock type. Option: internal clock 、 implicit clock、external clock.
terminal | external clock terminal,defined by enum JY9511_ExternalClockTerminal
rate | clock frequency,when clockType is implicit clock or external clock. when clockType is Internal clock, the rate is internal sample rate
Returns
0 if success or other error code

◆ JY9511_CI_SetSamplesToAcquire()

JY9511_API int JY9511_CI_SetSamplesToAcquire | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToAcquire )

Set samples to acquire in finite mode.The samples range is 1 to 4M.

Parameters
hDevice | device handle
channel | counter input channel
samplesToAcquire | CI finite samples to acquire, samples range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY9511_CI_SetSignalReverse()

JY9511_API int JY9511_CI_SetSignalReverse | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | signalReverse )

Set the Signal Reverse terminal.

Parameters
hDevice | device handle
channel | counter input channel
signalReverse | The lower 4bit is valid. 0bit represents Source, 1bit represents Gate, 2bit represents Aux, and 3bit represents Extclk
Returns
0 if success or other error code

◆ JY9511_CI_SetSourceTerminal()

JY9511_API int JY9511_CI_SetSourceTerminal | ( | JY9511_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY9511_InputTerminal | sourceTerminal )

Set source terminal.

Parameters
hDevice | device handle
channel | counter output channel
sourceTerminal | source terminal
Returns
0 if success or other error code

◆ JY9511_CI_SetStartingEdge()

JY9511_API int JY9511_CI_SetStartingEdge | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY9511_CI_StartingEdge | startingEdge )

Set start measure edge.

Parameters
hDevice | device handle
channel | counter input channel
startingEdge | start measure edge
Returns
0 if success or other error code

◆ JY9511_CI_SetStartTriggerType()

JY9511_API int JY9511_CI_SetStartTriggerType | ( | JY9511_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY9511_CI_TriggerType | triggerTyp )

Set CI start trigger type,the triggerType is defined by enum JY9511_CI_TriggerType.

Parameters
hDevice | device handle
channel | counter input channel
triggerType | CI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY9511_CI_SetTimeBase()

JY9511_API int JY9511_CI_SetTimeBase | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY9511_CountTimeBase | timebaseSrc,
 |  | JY9511_InputTerminal | externalTimebaseTerminal,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq )

Set CI timebase source.

Parameters
hDevice | device handle
channel | counter channel
timeBase | counter time base source.defined by emun JY9511_CountTimeBase.Options:JY9511_TimeBase_100M
externalTimebaseTerminal | counter external time base terminal.defined by emun JY9511_InputTerminal.
externalTimebaseFreq | counter external time base frequency.
actualTimebaseFreq | counter actual time base frequency.
Returns
0 if success or other error code

◆ JY9511_CI_Start()

JY9511_API int JY9511_CI_Start | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Start Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY9511_CI_Stop()

JY9511_API int JY9511_CI_Stop | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Stop Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY9511_Close()

JY9511_API int JY9511_Close ( JY9511_DeviceHandle hDevice )

关闭设备，释放句柄

Parameters
cardName | 板卡名
hDevice | 返回板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9511_DisableAICalibration()

JY9511_API int JY9511_DisableAICalibration | ( | JY9511_DeviceHandle | hDevice,
 |  | bool | DisableCalibration )

Disable AI calibration coefficient, default false.

Parameters
hDevice | 板卡句柄
enabled | 是否启用校准。若启用校准，Arm()时会应用从EEPROM读取的校准系数；若禁用校准，Arm()时会应用k=1.0, b=0.0
Returns
0：无错误；其它：发生错误

◆ JY9511_DisableAILinearityCalibration()

JY9511_API int JY9511_DisableAILinearityCalibration | ( | JY9511_DeviceHandle | hDevice,
 |  | bool | DisableCalibration )

Disable AI calibration coefficient, default false.

Parameters
hDevice | 板卡句柄
enabled | 是否启用校准。若启用校准，Arm()时会应用从EEPROM读取的校准系数；若禁用校准，Arm()时会应用k=1.0, b=0.0
Returns
0：无错误；其它：发生错误

◆ JY9511_DisableAOCalibration()

JY9511_API int JY9511_DisableAOCalibration | ( | JY9511_DeviceHandle | hDevice,
 |  | bool | DisableCalibration )

◆ JY9511_DisableAOLinearityCalibration()

JY9511_API int JY9511_DisableAOLinearityCalibration | ( | JY9511_DeviceHandle | hDevice,
 |  | bool | DisableCalibration )

◆ JY9511_DisconnectSignalRouting()

JY9511_API int JY9511_DisconnectSignalRouting | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_Signal_Destination | destination )

断开指定端口与内部信号的连接，复位到低电平

Parameters
hDevice | 板卡句柄
destination | 导出端口
Returns
0：无错误；其它：发生错误

◆ JY9511_GetBoardTemperature()

JY9511_API int JY9511_GetBoardTemperature | ( | JY9511_DeviceHandle | hDevice,
 |  | double * | temperature )

获取板卡温度

Parameters
hDevice | 板卡句柄
temperature | 返回值：板卡温度(℃)
Returns
0：无错误；其它：发生错误

◆ JY9511_GetDeviceID()

JY9511_API int JY9511_GetDeviceID | ( | JY9511_DeviceHandle | hDevice,
 |  | int * | deviceID )

Obtain the board ID.

The 9511 is a series of boards. The PXIe-9511 board ID is Ox9511. The PCIe-9511 board ID is OxA511. The USB-9511 board ID is OxB511

Parameters
hDevice | device handle
deviceID | board ID
Returns
0 if success or other error code

◆ JY9511_GetDeviceInfo()

JY9511_API int JY9511_GetDeviceInfo | ( | JY9511_DeviceHandle | hDevice,
 |  | unsigned char * | info )

获取设备信息

Parameters
hDevice | 板卡句柄
deviceID | 板卡ID
Returns
0：无错误；其它：发生错误

◆ JY9511_GetDeviceSerialNumber()

JY9511_API int JY9511_GetDeviceSerialNumber | ( | JY9511_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length )

Obtain the device serialNumber.

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,length is 10
Returns
0 if success or other error code

◆ JY9511_IdentifyTEDSChip()

JY9511_API int JY9511_IdentifyTEDSChip | ( | JY9511_DeviceHandle | hDevice,
 |  | int | chID,
 |  | unsigned long long * | romID,
 |  | int * | totalPageCount )

识别指定通道上连接的TEDS传感器的TEDS芯片（EEPROM），以获取其型号和存储容量。

Parameters
hDevice | 板卡句柄
chID | 要进行TEDS读写的通道
romID | TEDS芯片的64-bit ROM ID。该ID的低8-bit为表征器件型号的Family ID，中间48-bit为SN，高8-bit为CRC-8-Maxim校验码。
totalPageCount | 该TEDS芯片的Memory的总页数。每页长度固定为32bytes。
Returns
0：无错误；其它：发生错误

◆ JY9511_Open()

JY9511_API int JY9511_Open | ( | int | slotNumber,
 |  | JY9511_DeviceHandle * | hDevice )

打开板卡

Parameters
slotNumber | 板卡号
hDevice | 返回板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9511_OpenByName()

JY9511_API int JY9511_OpenByName | ( | const char * | cardName,
 |  | JY9511_DeviceHandle * | hDevice )

以别名打开板卡

Parameters
cardName | 板卡名
hDevice | 返回板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9511_ReadTEDSData()

JY9511_API int JY9511_ReadTEDSData | ( | JY9511_DeviceHandle | hDevice,
 |  | int | chID,
 |  | unsigned long long | romID,
 |  | char * | data,
 |  | int | readPageCount,
 |  | int | startPageIndex = 0 )

从指定通道上读取TEDS传感器的TEDS数据。比须在TEDS读写IO初始化之后再调用。

Parameters
hDevice | 板卡句柄
chID | 要执行TEDS读取的通道
romID | TEDS器件内存的64-bit ROM ID。通过 JY9511_IdetifyTEDSDevice() 获取该ID。
data | 数据缓存
readPageCount | 要读取的页的数量。固定从第1页开始读取，每页TEDS数据的长度固定为32bytes，总读取长度不得超过TEDS器件内存的总页数。通过过 JY9511T_IdetifyTEDSDevice() 获取TEDS内存器件的总页数。
Returns
成功：0 , 失败：!=0

◆ JY9511_SetDeviceReferenceClock()

JY9511_API int JY9511_SetDeviceReferenceClock | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_ReferenceClockSource | refClkSrc,
 |  | JY9511_ExteranlReferenceClockTerminal | externalrefclkterminal,
 |  | double | referenceClockRate )

◆ JY9511_SetDeviceStatusLed()

JY9511_API int JY9511_SetDeviceStatusLed | ( | JY9511_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | unsigned int | frequency )

Control Front Panel Status Led.

Parameters
hDevice | device handle
enable | enable front panel status led blink, true: blink, false: not blink
frequency | when enable is ture, the led blink speed by frequency define
Returns
0 if success or other error code

◆ JY9511_SignalRouting()

JY9511_API int JY9511_SignalRouting | ( | JY9511_DeviceHandle | hDevice,
 |  | JY9511_Signal_Source | source,
 |  | JY9511_Signal_Destination | destination )

导出内部信号到指定端口

Parameters
hDevice | 板卡句柄
destination | 导出端口
source | 要导出的信号
Returns
0：无错误；其它：发生错误
Generated by doxygen 1.15.0


9511 C++ Programming Manual: JY9511_info Struct Reference

Public Attributes | List of all members
JY9511_info Struct Reference

#include <JY9511.h>

Public Attributes

int | VID
int | PID
int | slotNum
bool | connected
int | cardNumber
bool | fStreaming
char | serialNumber [33]
char | vendorName [65]
char | model [65]
char | aliasName [65]
char | PlatformType [16]
char | HardwareVer [16]
char | FirmwareVer [16]
char | FrameworkVer [16]
char | DriverSetVer [16]
char | ProductionDate [16]

Member Data Documentation

◆ aliasName

char JY9511_info::aliasName[65]

◆ cardNumber

int JY9511_info::cardNumber

◆ connected

bool JY9511_info::connected

◆ DriverSetVer

char JY9511_info::DriverSetVer[16]

◆ FirmwareVer

char JY9511_info::FirmwareVer[16]

◆ FrameworkVer

char JY9511_info::FrameworkVer[16]

◆ fStreaming

bool JY9511_info::fStreaming

◆ HardwareVer

char JY9511_info::HardwareVer[16]

◆ model

char JY9511_info::model[65]

◆ PID

int JY9511_info::PID

◆ PlatformType

char JY9511_info::PlatformType[16]

◆ ProductionDate

char JY9511_info::ProductionDate[16]

◆ serialNumber

char JY9511_info::serialNumber[33]

◆ slotNum

int JY9511_info::slotNum

◆ vendorName

char JY9511_info::vendorName[65]

◆ VID

int JY9511_info::VID
The documentation for this struct was generated from the following file:
  • D:/OneDrive/Desktop/9511/C++/JY9511.h


9511 C++ Programming Manual: Class List

  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
C JY9511_info


9511 C++ Programming Manual: Class Index

  • Class List
  • Class Index
  • Class Members
Class Index
J
J
JY9511_info


9511 C++ Programming Manual: D:/OneDrive/Desktop/9511/C++ Directory Reference

  • File Members
  • OneDrive
  • Desktop
  • 9511
  • C++
C++ Directory Reference

Files

         JY9511.h


9511 C++ Programming Manual: D:/OneDrive/Desktop Directory Reference

  • OneDrive
  • Desktop
Desktop Directory Reference

Directories

         9511


9511 C++ Programming Manual: D:/OneDrive/Desktop/9511 Directory Reference

  • OneDrive
  • Desktop
  • 9511
9511 Directory Reference

Directories

         C++


9511 C++ Programming Manual: D:/OneDrive Directory Reference

  • OneDrive
OneDrive Directory Reference

Directories

         Desktop


9511 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 12345]
 OneDrive
Desktop
9511
C++
JY9511.h


9511 C++ Programming Manual: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
Here is a list of all class members with links to the classes they belong to:
  • aliasName : JY9511_info
  • cardNumber : JY9511_info
  • connected : JY9511_info
  • DriverSetVer : JY9511_info
  • FirmwareVer : JY9511_info
  • FrameworkVer : JY9511_info
  • fStreaming : JY9511_info
  • HardwareVer : JY9511_info
  • model : JY9511_info
  • PID : JY9511_info
  • PlatformType : JY9511_info
  • ProductionDate : JY9511_info
  • serialNumber : JY9511_info
  • slotNum : JY9511_info
  • vendorName : JY9511_info
  • VID : JY9511_info


9511 C++ Programming Manual: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
Here is a list of all variables with links to the classes they belong to:
  • aliasName : JY9511_info
  • cardNumber : JY9511_info
  • connected : JY9511_info
  • DriverSetVer : JY9511_info
  • FirmwareVer : JY9511_info
  • FrameworkVer : JY9511_info
  • fStreaming : JY9511_info
  • HardwareVer : JY9511_info
  • model : JY9511_info
  • PID : JY9511_info
  • PlatformType : JY9511_info
  • ProductionDate : JY9511_info
  • serialNumber : JY9511_info
  • slotNum : JY9511_info
  • vendorName : JY9511_info
  • VID : JY9511_info


9511 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all file members with links to the files they belong to:

- j -

  • JY9511_AC : JY9511.h
  • JY9511_AI_Analog : JY9511.h
  • JY9511_AI_CheckBufferStatus() : JY9511.h
  • JY9511_AI_CheckSyncStatus() : JY9511.h
  • JY9511_AI_Commit() : JY9511.h
  • JY9511_AI_ConfigSignalExport() : JY9511.h
  • JY9511_AI_ConfigSync() : JY9511.h
  • JY9511_AI_Continuous : JY9511.h
  • JY9511_AI_Coupling : JY9511.h
  • JY9511_AI_DetectIEPEConnection() : JY9511.h
  • JY9511_AI_Digital : JY9511.h
  • JY9511_AI_EnableChannel() : JY9511.h
  • JY9511_AI_Finite : JY9511.h
  • JY9511_AI_GetClkFreq() : JY9511.h
  • JY9511_AI_Immediately : JY9511.h
  • JY9511_AI_LPF_Normal : JY9511.h
  • JY9511_AI_LPF_WideBandwidth : JY9511.h
  • JY9511_AI_LPFMode : JY9511.h
  • JY9511_AI_MCLK_Input : JY9511.h
  • JY9511_AI_ParseSampleRate() : JY9511.h
  • JY9511_AI_Range : JY9511.h
  • JY9511_AI_Range_0p3125V : JY9511.h
  • JY9511_AI_Range_0p625V : JY9511.h
  • JY9511_AI_Range_10V : JY9511.h
  • JY9511_AI_Range_1p25V : JY9511.h
  • JY9511_AI_Range_25V : JY9511.h
  • JY9511_AI_Range_2p5V : JY9511.h
  • JY9511_AI_Range_50V : JY9511.h
  • JY9511_AI_Range_5V : JY9511.h
  • JY9511_AI_ReadData() : JY9511.h
  • JY9511_AI_ReadRawData() : JY9511.h
  • JY9511_AI_ReadRawSinglePoint() : JY9511.h
  • JY9511_AI_ReadSinglePoint() : JY9511.h
  • JY9511_AI_ReferenceTrig : JY9511.h
  • JY9511_AI_SampleClock_Input : JY9511.h
  • JY9511_AI_SampleMode : JY9511.h
  • JY9511_AI_SendSoftwareTrigger() : JY9511.h
  • JY9511_AI_SetAnalogEdgeReferenceTrigger() : JY9511.h
  • JY9511_AI_SetAnalogEdgeStartTrigger() : JY9511.h
  • JY9511_AI_SetAnalogHysteresisReferenceTrigger() : JY9511.h
  • JY9511_AI_SetAnalogHysteresisStartTrigger() : JY9511.h
  • JY9511_AI_SetAnalogWindowReferenceTrigger() : JY9511.h
  • JY9511_AI_SetAnalogWindowStartTrigger() : JY9511.h
  • JY9511_AI_SetBesselComp() : JY9511.h
  • JY9511_AI_SetDigitalReferenceTrigger() : JY9511.h
  • JY9511_AI_SetDigitalStartTrigger() : JY9511.h
  • JY9511_AI_SetLPFMode() : JY9511.h
  • JY9511_AI_SetPreTriggerSamples() : JY9511.h
  • JY9511_AI_SetReferenceTriggerType() : JY9511.h
  • JY9511_AI_SetReTriggerCount() : JY9511.h
  • JY9511_AI_SetSampleMode() : JY9511.h
  • JY9511_AI_SetSampleRate() : JY9511.h
  • JY9511_AI_SetSamplesToAcquire() : JY9511.h
  • JY9511_AI_SetStartTriggerType() : JY9511.h
  • JY9511_AI_Single : JY9511.h
  • JY9511_AI_Software : JY9511.h
  • JY9511_AI_Start() : JY9511.h
  • JY9511_AI_StartTrig : JY9511.h
  • JY9511_AI_Stop() : JY9511.h
  • JY9511_AI_Sync() : JY9511.h
  • JY9511_AI_TriggerType : JY9511.h
  • JY9511_AI_WaitUntilDone() : JY9511.h
  • JY9511_AnalogTriggerEdge : JY9511.h
  • JY9511_AnalogTriggerSource : JY9511.h
  • JY9511_AnalogWindowCondition : JY9511.h
  • JY9511_AnyEdge : JY9511.h
  • JY9511_AO_CheckBufferStatus() : JY9511.h
  • JY9511_AO_Commit() : JY9511.h
  • JY9511_AO_ConfigDDS() : JY9511.h
  • JY9511_AO_ConfigSync() : JY9511.h
  • JY9511_AO_ContinuousNoWrapping : JY9511.h
  • JY9511_AO_ContinuousWrapping : JY9511.h
  • JY9511_AO_DDS : JY9511.h
  • JY9511_AO_Digital : JY9511.h
  • JY9511_AO_EnableChannel() : JY9511.h
  • JY9511_AO_Finite : JY9511.h
  • JY9511_AO_GetPLL() : JY9511.h
  • JY9511_AO_Immediately : JY9511.h
  • JY9511_AO_ParseSampleRate() : JY9511.h
  • JY9511_AO_Range : JY9511.h
  • JY9511_AO_Range_0p316V : JY9511.h
  • JY9511_AO_Range_10V : JY9511.h
  • JY9511_AO_Range_1V : JY9511.h
  • JY9511_AO_Range_3p16V : JY9511.h
  • JY9511_AO_SampleClock_Input : JY9511.h
  • JY9511_AO_SendSoftTrigger() : JY9511.h
  • JY9511_AO_SetBesselComp() : JY9511.h
  • JY9511_AO_SetDigitalStartTrigger() : JY9511.h
  • JY9511_AO_SetMode() : JY9511.h
  • JY9511_AO_SetSamplesToUpdate() : JY9511.h
  • JY9511_AO_SetStartTriggerType() : JY9511.h
  • JY9511_AO_SetUpdateRate() : JY9511.h
  • JY9511_AO_Software : JY9511.h
  • JY9511_AO_Start() : JY9511.h
  • JY9511_AO_StartTrig : JY9511.h
  • JY9511_AO_Stop() : JY9511.h
  • JY9511_AO_TriggerType : JY9511.h
  • JY9511_AO_UpdateMode : JY9511.h
  • JY9511_AO_WaitUntilDone() : JY9511.h
  • JY9511_AO_WriteData() : JY9511.h
  • JY9511_AO_WriteRawData() : JY9511.h
  • JY9511_Channel_0 : JY9511.h
  • JY9511_Channel_1 : JY9511.h
  • JY9511_Channel_2 : JY9511.h
  • JY9511_Channel_3 : JY9511.h
  • JY9511_CI_100kHz_Input : JY9511.h
  • JY9511_CI_100MHz_Input : JY9511.h
  • JY9511_CI_5MHz_Input : JY9511.h
  • JY9511_CI_CheckBufferStatus() : JY9511.h
  • JY9511_CI_Continuous : JY9511.h
  • JY9511_CI_Count_Down : JY9511.h
  • JY9511_CI_Count_External : JY9511.h
  • JY9511_CI_Count_Up : JY9511.h
  • JY9511_CI_CounterEventSignalIdleState : JY9511.h
  • JY9511_CI_CounterEventSignalIdleState_High : JY9511.h
  • JY9511_CI_CounterEventSignalIdleState_Low : JY9511.h
  • JY9511_CI_EdgeCount : JY9511.h
  • JY9511_CI_EnableChannel() : JY9511.h
  • JY9511_CI_ExternalClock : JY9511.h
  • JY9511_CI_Finite : JY9511.h
  • JY9511_CI_ImplicitClock : JY9511.h
  • JY9511_CI_InternalClock : JY9511.h
  • JY9511_CI_Measure_FrequencyOrPeriod : JY9511.h
  • JY9511_CI_Measure_PulseWidth : JY9511.h
  • JY9511_CI_Measure_SemiPeriod : JY9511.h
  • JY9511_CI_MeasureType : JY9511.h
  • JY9511_CI_ReadCountValues() : JY9511.h
  • JY9511_CI_ReadMeasureValues() : JY9511.h
  • JY9511_CI_ReadSingleCountValue() : JY9511.h
  • JY9511_CI_ReadSingleMeasureValue() : JY9511.h
  • JY9511_CI_SampleClock : JY9511.h
  • JY9511_CI_SampleMode : JY9511.h
  • JY9511_CI_SendSoftTrigger() : JY9511.h
  • JY9511_CI_SetCounterParament() : JY9511.h
  • JY9511_CI_SetCounterType() : JY9511.h
  • JY9511_CI_SetDigitalStartTrigger() : JY9511.h
  • JY9511_CI_SetEdgeCountEvent() : JY9511.h
  • JY9511_CI_SetEdgeCountEventEx() : JY9511.h
  • JY9511_CI_SetFirstSampleClock() : JY9511.h
  • JY9511_CI_SetGateTerminal() : JY9511.h
  • JY9511_CI_SetMode() : JY9511.h
  • JY9511_CI_SetPauseTriggerLevel() : JY9511.h
  • JY9511_CI_SetPauseTriggerTerminal() : JY9511.h
  • JY9511_CI_SetSampleClock() : JY9511.h
  • JY9511_CI_SetSamplesToAcquire() : JY9511.h
  • JY9511_CI_SetSignalReverse() : JY9511.h
  • JY9511_CI_SetSourceTerminal() : JY9511.h
  • JY9511_CI_SetStartingEdge() : JY9511.h
  • JY9511_CI_SetStartTriggerType() : JY9511.h
  • JY9511_CI_SetTimeBase() : JY9511.h
  • JY9511_CI_Single : JY9511.h
  • JY9511_CI_Start() : JY9511.h
  • JY9511_CI_StartingEdge : JY9511.h
  • JY9511_CI_Stop() : JY9511.h
  • JY9511_CI_TriggerType : JY9511.h
  • JY9511_CIO_Digital : JY9511.h
  • JY9511_CIO_Immediately : JY9511.h
  • JY9511_CIO_Soft : JY9511.h
  • JY9511_Clock_In : JY9511.h
  • JY9511_Clock_PXI_Trig_0 : JY9511.h
  • JY9511_Clock_PXI_Trig_1 : JY9511.h
  • JY9511_Clock_PXI_Trig_2 : JY9511.h
  • JY9511_Clock_PXI_Trig_3 : JY9511.h
  • JY9511_Clock_PXI_Trig_4 : JY9511.h
  • JY9511_Clock_PXI_Trig_5 : JY9511.h
  • JY9511_Clock_PXI_Trig_6 : JY9511.h
  • JY9511_Clock_PXI_Trig_7 : JY9511.h
  • JY9511_Close() : JY9511.h
  • JY9511_CountDirection : JY9511.h
  • JY9511_CountTimeBase : JY9511.h
  • JY9511_DC : JY9511.h
  • JY9511_DeviceHandle : JY9511.h
  • JY9511_DeviceProperty : JY9511.h
  • JY9511_Difference : JY9511.h
  • JY9511_DigitalTriggerEdge : JY9511.h
  • JY9511_DigitalTriggerSource : JY9511.h
  • JY9511_DisableAICalibration() : JY9511.h
  • JY9511_DisableAILinearityCalibration() : JY9511.h
  • JY9511_DisableAOCalibration() : JY9511.h
  • JY9511_DisableAOLinearityCalibration() : JY9511.h
  • JY9511_DisconnectSignalRouting() : JY9511.h
  • JY9511_Entering : JY9511.h
  • JY9511_ExteranlReferenceClockTerminal : JY9511.h
  • JY9511_External : JY9511.h
  • JY9511_External_Timebase : JY9511.h
  • JY9511_ExternalClockTerminal : JY9511.h
  • JY9511_Falling : JY9511.h
  • JY9511_FallingEdge : JY9511.h
  • JY9511_FallingSlope : JY9511.h
  • JY9511_GetBoardTemperature() : JY9511.h
  • JY9511_GetDeviceID() : JY9511.h
  • JY9511_GetDeviceInfo() : JY9511.h
  • JY9511_GetDeviceSerialNumber() : JY9511.h
  • JY9511_HighLevel : JY9511.h
  • JY9511_IdentifyTEDSChip() : JY9511.h
  • JY9511_IEPEConnection_Normal : JY9511.h
  • JY9511_IEPEConnection_Open : JY9511.h
  • JY9511_IEPEConnection_Short : JY9511.h
  • JY9511_IEPEConnectionStatus : JY9511.h
  • JY9511_Independent : JY9511.h
  • JY9511_InputTerminal : JY9511.h
  • JY9511_Inter_AI_ReferenceTrig : JY9511.h
  • JY9511_Inter_AI_StartTrig : JY9511.h
  • JY9511_Inter_AO_StartTrig : JY9511.h
  • JY9511_Inter_Counter_0_StartTrig : JY9511.h
  • JY9511_Internal : JY9511.h
  • JY9511_Internal_Timebase_100K : JY9511.h
  • JY9511_Internal_Timebase_100M : JY9511.h
  • JY9511_Internal_Timebase_5M : JY9511.h
  • JY9511_Leaving : JY9511.h
  • JY9511_LevelState : JY9511.h
  • JY9511_LowLevel : JY9511.h
  • JY9511_MASTER : JY9511.h
  • JY9511_MCLK_Timebase : JY9511.h
  • JY9511_Open() : JY9511.h
  • JY9511_OpenByName() : JY9511.h
  • JY9511_PFI0 : JY9511.h
  • JY9511_PFI0_Input : JY9511.h
  • JY9511_PFI0_OUT : JY9511.h
  • JY9511_PseudoDifference : JY9511.h
  • JY9511_PXI_Trig0 : JY9511.h
  • JY9511_PXI_Trig0_Input : JY9511.h
  • JY9511_PXI_Trig1 : JY9511.h
  • JY9511_PXI_Trig1_Input : JY9511.h
  • JY9511_PXI_Trig2 : JY9511.h
  • JY9511_PXI_Trig2_Input : JY9511.h
  • JY9511_PXI_Trig3 : JY9511.h
  • JY9511_PXI_Trig3_Input : JY9511.h
  • JY9511_PXI_Trig4 : JY9511.h
  • JY9511_PXI_Trig4_Input : JY9511.h
  • JY9511_PXI_Trig5 : JY9511.h
  • JY9511_PXI_Trig5_Input : JY9511.h
  • JY9511_PXI_Trig6 : JY9511.h
  • JY9511_PXI_Trig6_Input : JY9511.h
  • JY9511_PXI_Trig7 : JY9511.h
  • JY9511_PXI_Trig7_Input : JY9511.h
  • JY9511_PXIe_Clk100 : JY9511.h
  • JY9511_PXITrig0_OUT : JY9511.h
  • JY9511_PXITrig1_OUT : JY9511.h
  • JY9511_PXITrig2_OUT : JY9511.h
  • JY9511_PXITrig3_OUT : JY9511.h
  • JY9511_PXITrig4_OUT : JY9511.h
  • JY9511_PXITrig5_OUT : JY9511.h
  • JY9511_PXITrig6_OUT : JY9511.h
  • JY9511_PXITrig7_OUT : JY9511.h
  • JY9511_ReadTEDSData() : JY9511.h
  • JY9511_ReferenceClockSource : JY9511.h
  • JY9511_ReferenceTrigger : JY9511.h
  • JY9511_Rising : JY9511.h
  • JY9511_RisingEdge : JY9511.h
  • JY9511_RisingSlope : JY9511.h
  • JY9511_SetDeviceReferenceClock() : JY9511.h
  • JY9511_SetDeviceStatusLed() : JY9511.h
  • JY9511_Signa_Counter_0_EventOut : JY9511.h
  • JY9511_Signal_CI_0_SampleClock : JY9511.h
  • JY9511_Signal_CI_0_StartTrig : JY9511.h
  • JY9511_Signal_Destination : JY9511.h
  • JY9511_Signal_PFI_0 : JY9511.h
  • JY9511_Signal_PXI_Trig_0 : JY9511.h
  • JY9511_Signal_PXI_Trig_1 : JY9511.h
  • JY9511_Signal_PXI_Trig_2 : JY9511.h
  • JY9511_Signal_PXI_Trig_3 : JY9511.h
  • JY9511_Signal_PXI_Trig_4 : JY9511.h
  • JY9511_Signal_PXI_Trig_5 : JY9511.h
  • JY9511_Signal_PXI_Trig_6 : JY9511.h
  • JY9511_Signal_PXI_Trig_7 : JY9511.h
  • JY9511_Signal_Source : JY9511.h
  • JY9511_SignalRouting() : JY9511.h
  • JY9511_SLAVE : JY9511.h
  • JY9511_StartTrigger : JY9511.h
  • JY9511_Terminal : JY9511.h
  • JY9511_TriggerMode : JY9511.h


9511 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all enums with links to the files they belong to:

- j -

  • JY9511_AI_Coupling : JY9511.h
  • JY9511_AI_LPFMode : JY9511.h
  • JY9511_AI_Range : JY9511.h
  • JY9511_AI_SampleMode : JY9511.h
  • JY9511_AI_TriggerType : JY9511.h
  • JY9511_AnalogTriggerEdge : JY9511.h
  • JY9511_AnalogTriggerSource : JY9511.h
  • JY9511_AnalogWindowCondition : JY9511.h
  • JY9511_AO_Range : JY9511.h
  • JY9511_AO_TriggerType : JY9511.h
  • JY9511_AO_UpdateMode : JY9511.h
  • JY9511_CI_CounterEventSignalIdleState : JY9511.h
  • JY9511_CI_MeasureType : JY9511.h
  • JY9511_CI_SampleClock : JY9511.h
  • JY9511_CI_SampleMode : JY9511.h
  • JY9511_CI_StartingEdge : JY9511.h
  • JY9511_CI_TriggerType : JY9511.h
  • JY9511_CountDirection : JY9511.h
  • JY9511_CountTimeBase : JY9511.h
  • JY9511_DeviceProperty : JY9511.h
  • JY9511_DigitalTriggerEdge : JY9511.h
  • JY9511_DigitalTriggerSource : JY9511.h
  • JY9511_ExteranlReferenceClockTerminal : JY9511.h
  • JY9511_ExternalClockTerminal : JY9511.h
  • JY9511_IEPEConnectionStatus : JY9511.h
  • JY9511_InputTerminal : JY9511.h
  • JY9511_LevelState : JY9511.h
  • JY9511_ReferenceClockSource : JY9511.h
  • JY9511_Signal_Destination : JY9511.h
  • JY9511_Signal_Source : JY9511.h
  • JY9511_Terminal : JY9511.h
  • JY9511_TriggerMode : JY9511.h


9511 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all enum values with links to the files they belong to:

- j -

  • JY9511_AC : JY9511.h
  • JY9511_AI_Analog : JY9511.h
  • JY9511_AI_Continuous : JY9511.h
  • JY9511_AI_Digital : JY9511.h
  • JY9511_AI_Finite : JY9511.h
  • JY9511_AI_Immediately : JY9511.h
  • JY9511_AI_LPF_Normal : JY9511.h
  • JY9511_AI_LPF_WideBandwidth : JY9511.h
  • JY9511_AI_MCLK_Input : JY9511.h
  • JY9511_AI_Range_0p3125V : JY9511.h
  • JY9511_AI_Range_0p625V : JY9511.h
  • JY9511_AI_Range_10V : JY9511.h
  • JY9511_AI_Range_1p25V : JY9511.h
  • JY9511_AI_Range_25V : JY9511.h
  • JY9511_AI_Range_2p5V : JY9511.h
  • JY9511_AI_Range_50V : JY9511.h
  • JY9511_AI_Range_5V : JY9511.h
  • JY9511_AI_ReferenceTrig : JY9511.h
  • JY9511_AI_SampleClock_Input : JY9511.h
  • JY9511_AI_Single : JY9511.h
  • JY9511_AI_Software : JY9511.h
  • JY9511_AI_StartTrig : JY9511.h
  • JY9511_AnyEdge : JY9511.h
  • JY9511_AO_ContinuousNoWrapping : JY9511.h
  • JY9511_AO_ContinuousWrapping : JY9511.h
  • JY9511_AO_DDS : JY9511.h
  • JY9511_AO_Digital : JY9511.h
  • JY9511_AO_Finite : JY9511.h
  • JY9511_AO_Immediately : JY9511.h
  • JY9511_AO_Range_0p316V : JY9511.h
  • JY9511_AO_Range_10V : JY9511.h
  • JY9511_AO_Range_1V : JY9511.h
  • JY9511_AO_Range_3p16V : JY9511.h
  • JY9511_AO_SampleClock_Input : JY9511.h
  • JY9511_AO_Software : JY9511.h
  • JY9511_AO_StartTrig : JY9511.h
  • JY9511_Channel_0 : JY9511.h
  • JY9511_Channel_1 : JY9511.h
  • JY9511_Channel_2 : JY9511.h
  • JY9511_Channel_3 : JY9511.h
  • JY9511_CI_100kHz_Input : JY9511.h
  • JY9511_CI_100MHz_Input : JY9511.h
  • JY9511_CI_5MHz_Input : JY9511.h
  • JY9511_CI_Continuous : JY9511.h
  • JY9511_CI_Count_Down : JY9511.h
  • JY9511_CI_Count_External : JY9511.h
  • JY9511_CI_Count_Up : JY9511.h
  • JY9511_CI_CounterEventSignalIdleState_High : JY9511.h
  • JY9511_CI_CounterEventSignalIdleState_Low : JY9511.h
  • JY9511_CI_EdgeCount : JY9511.h
  • JY9511_CI_ExternalClock : JY9511.h
  • JY9511_CI_Finite : JY9511.h
  • JY9511_CI_ImplicitClock : JY9511.h
  • JY9511_CI_InternalClock : JY9511.h
  • JY9511_CI_Measure_FrequencyOrPeriod : JY9511.h
  • JY9511_CI_Measure_PulseWidth : JY9511.h
  • JY9511_CI_Measure_SemiPeriod : JY9511.h
  • JY9511_CI_Single : JY9511.h
  • JY9511_CIO_Digital : JY9511.h
  • JY9511_CIO_Immediately : JY9511.h
  • JY9511_CIO_Soft : JY9511.h
  • JY9511_Clock_In : JY9511.h
  • JY9511_Clock_PXI_Trig_0 : JY9511.h
  • JY9511_Clock_PXI_Trig_1 : JY9511.h
  • JY9511_Clock_PXI_Trig_2 : JY9511.h
  • JY9511_Clock_PXI_Trig_3 : JY9511.h
  • JY9511_Clock_PXI_Trig_4 : JY9511.h
  • JY9511_Clock_PXI_Trig_5 : JY9511.h
  • JY9511_Clock_PXI_Trig_6 : JY9511.h
  • JY9511_Clock_PXI_Trig_7 : JY9511.h
  • JY9511_DC : JY9511.h
  • JY9511_Difference : JY9511.h
  • JY9511_Entering : JY9511.h
  • JY9511_External : JY9511.h
  • JY9511_External_Timebase : JY9511.h
  • JY9511_Falling : JY9511.h
  • JY9511_FallingEdge : JY9511.h
  • JY9511_FallingSlope : JY9511.h
  • JY9511_HighLevel : JY9511.h
  • JY9511_IEPEConnection_Normal : JY9511.h
  • JY9511_IEPEConnection_Open : JY9511.h
  • JY9511_IEPEConnection_Short : JY9511.h
  • JY9511_Independent : JY9511.h
  • JY9511_Inter_AI_ReferenceTrig : JY9511.h
  • JY9511_Inter_AI_StartTrig : JY9511.h
  • JY9511_Inter_AO_StartTrig : JY9511.h
  • JY9511_Inter_Counter_0_StartTrig : JY9511.h
  • JY9511_Internal : JY9511.h
  • JY9511_Internal_Timebase_100K : JY9511.h
  • JY9511_Internal_Timebase_100M : JY9511.h
  • JY9511_Internal_Timebase_5M : JY9511.h
  • JY9511_Leaving : JY9511.h
  • JY9511_LowLevel : JY9511.h
  • JY9511_MASTER : JY9511.h
  • JY9511_MCLK_Timebase : JY9511.h
  • JY9511_PFI0 : JY9511.h
  • JY9511_PFI0_Input : JY9511.h
  • JY9511_PFI0_OUT : JY9511.h
  • JY9511_PseudoDifference : JY9511.h
  • JY9511_PXI_Trig0 : JY9511.h
  • JY9511_PXI_Trig0_Input : JY9511.h
  • JY9511_PXI_Trig1 : JY9511.h
  • JY9511_PXI_Trig1_Input : JY9511.h
  • JY9511_PXI_Trig2 : JY9511.h
  • JY9511_PXI_Trig2_Input : JY9511.h
  • JY9511_PXI_Trig3 : JY9511.h
  • JY9511_PXI_Trig3_Input : JY9511.h
  • JY9511_PXI_Trig4 : JY9511.h
  • JY9511_PXI_Trig4_Input : JY9511.h
  • JY9511_PXI_Trig5 : JY9511.h
  • JY9511_PXI_Trig5_Input : JY9511.h
  • JY9511_PXI_Trig6 : JY9511.h
  • JY9511_PXI_Trig6_Input : JY9511.h
  • JY9511_PXI_Trig7 : JY9511.h
  • JY9511_PXI_Trig7_Input : JY9511.h
  • JY9511_PXIe_Clk100 : JY9511.h
  • JY9511_PXITrig0_OUT : JY9511.h
  • JY9511_PXITrig1_OUT : JY9511.h
  • JY9511_PXITrig2_OUT : JY9511.h
  • JY9511_PXITrig3_OUT : JY9511.h
  • JY9511_PXITrig4_OUT : JY9511.h
  • JY9511_PXITrig5_OUT : JY9511.h
  • JY9511_PXITrig6_OUT : JY9511.h
  • JY9511_PXITrig7_OUT : JY9511.h
  • JY9511_ReferenceTrigger : JY9511.h
  • JY9511_Rising : JY9511.h
  • JY9511_RisingEdge : JY9511.h
  • JY9511_RisingSlope : JY9511.h
  • JY9511_Signa_Counter_0_EventOut : JY9511.h
  • JY9511_Signal_CI_0_SampleClock : JY9511.h
  • JY9511_Signal_CI_0_StartTrig : JY9511.h
  • JY9511_Signal_PFI_0 : JY9511.h
  • JY9511_Signal_PXI_Trig_0 : JY9511.h
  • JY9511_Signal_PXI_Trig_1 : JY9511.h
  • JY9511_Signal_PXI_Trig_2 : JY9511.h
  • JY9511_Signal_PXI_Trig_3 : JY9511.h
  • JY9511_Signal_PXI_Trig_4 : JY9511.h
  • JY9511_Signal_PXI_Trig_5 : JY9511.h
  • JY9511_Signal_PXI_Trig_6 : JY9511.h
  • JY9511_Signal_PXI_Trig_7 : JY9511.h
  • JY9511_SLAVE : JY9511.h
  • JY9511_StartTrigger : JY9511.h


9511 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JY9511_AI_CheckBufferStatus() : JY9511.h
  • JY9511_AI_CheckSyncStatus() : JY9511.h
  • JY9511_AI_Commit() : JY9511.h
  • JY9511_AI_ConfigSignalExport() : JY9511.h
  • JY9511_AI_ConfigSync() : JY9511.h
  • JY9511_AI_DetectIEPEConnection() : JY9511.h
  • JY9511_AI_EnableChannel() : JY9511.h
  • JY9511_AI_GetClkFreq() : JY9511.h
  • JY9511_AI_ParseSampleRate() : JY9511.h
  • JY9511_AI_ReadData() : JY9511.h
  • JY9511_AI_ReadRawData() : JY9511.h
  • JY9511_AI_ReadRawSinglePoint() : JY9511.h
  • JY9511_AI_ReadSinglePoint() : JY9511.h
  • JY9511_AI_SendSoftwareTrigger() : JY9511.h
  • JY9511_AI_SetAnalogEdgeReferenceTrigger() : JY9511.h
  • JY9511_AI_SetAnalogEdgeStartTrigger() : JY9511.h
  • JY9511_AI_SetAnalogHysteresisReferenceTrigger() : JY9511.h
  • JY9511_AI_SetAnalogHysteresisStartTrigger() : JY9511.h
  • JY9511_AI_SetAnalogWindowReferenceTrigger() : JY9511.h
  • JY9511_AI_SetAnalogWindowStartTrigger() : JY9511.h
  • JY9511_AI_SetBesselComp() : JY9511.h
  • JY9511_AI_SetDigitalReferenceTrigger() : JY9511.h
  • JY9511_AI_SetDigitalStartTrigger() : JY9511.h
  • JY9511_AI_SetLPFMode() : JY9511.h
  • JY9511_AI_SetPreTriggerSamples() : JY9511.h
  • JY9511_AI_SetReferenceTriggerType() : JY9511.h
  • JY9511_AI_SetReTriggerCount() : JY9511.h
  • JY9511_AI_SetSampleMode() : JY9511.h
  • JY9511_AI_SetSampleRate() : JY9511.h
  • JY9511_AI_SetSamplesToAcquire() : JY9511.h
  • JY9511_AI_SetStartTriggerType() : JY9511.h
  • JY9511_AI_Start() : JY9511.h
  • JY9511_AI_Stop() : JY9511.h
  • JY9511_AI_Sync() : JY9511.h
  • JY9511_AI_WaitUntilDone() : JY9511.h
  • JY9511_AO_CheckBufferStatus() : JY9511.h
  • JY9511_AO_Commit() : JY9511.h
  • JY9511_AO_ConfigDDS() : JY9511.h
  • JY9511_AO_ConfigSync() : JY9511.h
  • JY9511_AO_EnableChannel() : JY9511.h
  • JY9511_AO_GetPLL() : JY9511.h
  • JY9511_AO_ParseSampleRate() : JY9511.h
  • JY9511_AO_SendSoftTrigger() : JY9511.h
  • JY9511_AO_SetBesselComp() : JY9511.h
  • JY9511_AO_SetDigitalStartTrigger() : JY9511.h
  • JY9511_AO_SetMode() : JY9511.h
  • JY9511_AO_SetSamplesToUpdate() : JY9511.h
  • JY9511_AO_SetStartTriggerType() : JY9511.h
  • JY9511_AO_SetUpdateRate() : JY9511.h
  • JY9511_AO_Start() : JY9511.h
  • JY9511_AO_Stop() : JY9511.h
  • JY9511_AO_WaitUntilDone() : JY9511.h
  • JY9511_AO_WriteData() : JY9511.h
  • JY9511_AO_WriteRawData() : JY9511.h
  • JY9511_CI_CheckBufferStatus() : JY9511.h
  • JY9511_CI_EnableChannel() : JY9511.h
  • JY9511_CI_ReadCountValues() : JY9511.h
  • JY9511_CI_ReadMeasureValues() : JY9511.h
  • JY9511_CI_ReadSingleCountValue() : JY9511.h
  • JY9511_CI_ReadSingleMeasureValue() : JY9511.h
  • JY9511_CI_SendSoftTrigger() : JY9511.h
  • JY9511_CI_SetCounterParament() : JY9511.h
  • JY9511_CI_SetCounterType() : JY9511.h
  • JY9511_CI_SetDigitalStartTrigger() : JY9511.h
  • JY9511_CI_SetEdgeCountEvent() : JY9511.h
  • JY9511_CI_SetEdgeCountEventEx() : JY9511.h
  • JY9511_CI_SetFirstSampleClock() : JY9511.h
  • JY9511_CI_SetGateTerminal() : JY9511.h
  • JY9511_CI_SetMode() : JY9511.h
  • JY9511_CI_SetPauseTriggerLevel() : JY9511.h
  • JY9511_CI_SetPauseTriggerTerminal() : JY9511.h
  • JY9511_CI_SetSampleClock() : JY9511.h
  • JY9511_CI_SetSamplesToAcquire() : JY9511.h
  • JY9511_CI_SetSignalReverse() : JY9511.h
  • JY9511_CI_SetSourceTerminal() : JY9511.h
  • JY9511_CI_SetStartingEdge() : JY9511.h
  • JY9511_CI_SetStartTriggerType() : JY9511.h
  • JY9511_CI_SetTimeBase() : JY9511.h
  • JY9511_CI_Start() : JY9511.h
  • JY9511_CI_Stop() : JY9511.h
  • JY9511_Close() : JY9511.h
  • JY9511_DisableAICalibration() : JY9511.h
  • JY9511_DisableAILinearityCalibration() : JY9511.h
  • JY9511_DisableAOCalibration() : JY9511.h
  • JY9511_DisableAOLinearityCalibration() : JY9511.h
  • JY9511_DisconnectSignalRouting() : JY9511.h
  • JY9511_GetBoardTemperature() : JY9511.h
  • JY9511_GetDeviceID() : JY9511.h
  • JY9511_GetDeviceInfo() : JY9511.h
  • JY9511_GetDeviceSerialNumber() : JY9511.h
  • JY9511_IdentifyTEDSChip() : JY9511.h
  • JY9511_Open() : JY9511.h
  • JY9511_OpenByName() : JY9511.h
  • JY9511_ReadTEDSData() : JY9511.h
  • JY9511_SetDeviceReferenceClock() : JY9511.h
  • JY9511_SetDeviceStatusLed() : JY9511.h
  • JY9511_SignalRouting() : JY9511.h


9511 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
Here is a list of all typedefs with links to the files they belong to:
  • JY9511_DeviceHandle : JY9511.h


9511 C++ Programming Manual: Main Page

9511 C++ Programming Manual Documentation


9511 C++ Programming Manual: Member List

  • Class List
  • Class Index
  • Class Members
JY9511_info Member List

This is the complete list of members for JY9511_info, including all inherited members.

aliasName | JY9511_info
cardNumber | JY9511_info
connected | JY9511_info
DriverSetVer | JY9511_info
FirmwareVer | JY9511_info
FrameworkVer | JY9511_info
fStreaming | JY9511_info
HardwareVer | JY9511_info
model | JY9511_info
PID | JY9511_info
PlatformType | JY9511_info
ProductionDate | JY9511_info
serialNumber | JY9511_info
slotNum | JY9511_info
vendorName | JY9511_info
VID | JY9511_info